Mozilla asks for news server authentication information although stored in the password manager.

RESOLVED FIXED

Status

MailNews Core
Networking: NNTP
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Mark Stier, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

The strange thing is that this happens randomly. Eg. if choosing "offline/sync"
to download many newsgroup articles, it first starts without asking for
login/pwd. Then, in the middle of the process, it sometimes asks me to enter a
password although I have several times enetered it before and stored it in the
password database. I don't exactly know the reason for that. It seems that this
happens preferably (only?) when switching between newsgroups. Additionally, it
sometimes also happens when _manually_ switching between newsgroups. It could in
some way related to the fact that my news provider only allows 4 simultaneous
connections. If that is the reason, then Mozilla does not force connections soon
enough or fails to reuse them. But if that is the case, the connection must be
dropped while displaying the authentication dialog becauser after manually
reentering the login information, Mozilla proceeds successfully until the next
authentication(?) failure.

Reproducible: Always

Steps to Reproduce:
1. Connect to a news server that requires authentication and allows no more than
3 or 4 simultaneous connections
2. Subscribe to many newsgroups.
3. Select the newsgroup to be downloaded for offline reading.
4. Start downloading of the articles by starting the offline/sync thing.
5. Don't forget to store authentication information for the server in Mozilla's
pad db.
6. Wait until Mozilla newsmail requires You to reenter the pwd.

Actual Results:  
The mailnews UI requests to reenter login information for the news server, and
while I don't see any entry in the pwd db belonging to the news server (although
it abviously has stored the pwd somewhere), I see many entries belonging to the
specific newsgroup URIs -- but each without user name information (just "<>").

Expected Results:  
Obvious.
(Reporter)

Comment 1

15 years ago
Step 3 to reproduce must of course read: "Select many newsgroups to be
downloaded for offline reading."

Comment 2

15 years ago
I've had Mozilla do this to me, also. For me it happened on Microsoft's private
beta newsgroups. There are multiple groups on the same server. I had to enter
the username and password for each, as I'd expect, but sometimes when I go back
to a newsgroup it will ask for one, the other, or both again. No particular
pattern that I can see.

I'd like to be able to come up with something specific; work. I don't use
newsgroups that much.
I have been experiencing same problem since my provider introduced password
protection on news server in April 2002 (Note: it is not 2003).
This problem still occurs sometimes with newest Mozilla trunk builds. 
If I reply "CANCEL" on userid/password prompt when clicked a news post, message
body of the post will not downloaded anymore although other posts can be read
normally.
Because unsubscribe and re-subscribe was required to read the missing body of
the post, I should enter userword/password again on userid/password prompt. 
This problem occurred many many times but I also could not find specific patern yet.
Sigh...

Comment 4

15 years ago
Same problem here with 2003071814/Mozilla 1.5a for Windows. This has been a
problem for years so much so that I just don't use Mozilla for NNTP anymore
besides at work. I too experience the problem with hitting cancel, message
doesn't load, clicking off group and then back on and entering login and
password, and then being unable to load the message that was highlighted when I
hit cancel. Sometimes the message loads even when I hit cancel.

I also can't find a preference to tell Mozilla to only open X connections to my
NNTP provider.

Comment 5

15 years ago
Same problem here as Robert Morris.
When connecting to de.* newsgroups or org.eclipse.* he asks me for username or
password or both repeatedly. Pops out in no obvious pattern. 
PasswordManager shows <newsserver><path>#<username> and <password>, but no
username in the next column, only <>.
I have two accounts open but only the default profile.
Fez

Comment 6

15 years ago
I still see it on build 2003082705 (1.5b). Trying to confirm per this comment
and many previous.

I am asked for password randomly not only when switching between groups, but
also when advancing to the next message. 
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

15 years ago
I have checked the password manager that the user name is not set correctly,
i.e. password manager presents an empty user name for the groups, even if
provided sthg else in the user/pasword popups. This may mean that user name (at
least) is not stored properly in the manager or is not displayed correctly. If
the first holds then bug 67432 may be fixed together. 
There is another newsgroup related bug 36816, "news should use the server's
username / password when authenticating".
Which is main cause of this problem, bug 67432 or bug 36816? 
Fix of bug 36816 has resolved this bug?

I access two news servers on which news server basis authentication is required
(not newsgroup basis authentication) and I also saw many password entries of
following format.
   Site=news://<NewsServerName>:119/<NewGroupName>#password , Username=<>
   Site=news://<NewsServerName>:119/<NewGroupName>#username , Username=<>
In addition, I saw a set of entries for a news server without <NewsGroupName>.
   Site=news://<NewsServerName>:119/#password , Username=<>
   Site=news://<NewsServerName>:119/#username , Username=<>

After deletion of all above password entries, With 20030912-trunk/Win-Me,
Mozilla created a set of entries for first newsgroup only on first newsgroup
access.  
 (for newsall.dti.ne.jp)
   Site=news://newsall.dti.ne.jp:119/dti.announce#password , Username=<>
   Site=news://newsall.dti.ne.jp:119/dti.announce#username , Username=<>
 (for news3.dti.ne.jp)
   Site=news://news3.dti.ne.jp:119/fj.1st-readme#password , Username=<>
   Site=news://news3.dti.ne.jp:119/fj.1st-readme#username , Username=<>
All newsgroup access can be done without password prompting.

And when I try to post to dti.support.misc on newsall.dti.ne.jp,
Mozilla prompted username/password twice and next sets of password entries were
created, one has no NewsGroupName and another has NewsGroupName.
 (Without NewsGroupName)
   Site=news://newsall.dti.ne.jp:119/#password , Username=<>
   Site=news://newsall.dti.ne.jp:119/#username , Username=<>
 (With NewsGroupName)
   Site=news://newsall.dti.ne.jp:119/dti.support.misc#password , Username=<>
   Site=news://newsall.dti.ne.jp:119/dti.support.misc#username , Username=<>
 
However, Mozilla did not prompted username/password on posting to a
newsgroup(other than 1st-readme) on news3.dti.ne.jp.
This difference seems to be caused by my operation, such as clicking another
newsgroup or mail folder after start of composing a news post.

With 2003091604-trunk/Win-Me, on which bug 36816 has been fixed, test result was
slightly different.

After deletion of all password entries for news, Mozilla created a set of
password entries of no NewsGroupName on first access to news.
 (for newsall.dti.ne.jp)
   Site=news://newsall.dti.ne.jp:119/#password , Username=<>
   Site=news://newsall.dti.ne.jp:119/#username , Username=<>
 (for news3.dti.ne.jp)
   Site=news://news3.dti.ne.jp:119/#password , Username=<>
   Site=news://news3.dti.ne.jp:119/#username , Username=<>
I have not experienced additional username/password promting for these 3 days.

Does this mean that no newsgroup specific username/password will not be used if
News Server does not use newsgroup basis security?
Has fix of bug 36816 resolved this problem?

Comment 10

15 years ago
I've tracked the problem down to the fact that the networkconnectionto the
newsserver has been dropped while reading or waiting for anything else.
collapsing all groups of the server and expanding them again reconnects using
the correct password. See bug 220010 for detials (in Thunderbird).
Bug 201749 has been closed as DUPE of bug 36816.
Does it mean this bug 214533 is also DUPE of bug 36816 ?

Comment 12

15 years ago
WADA, I think so.
Though it looks like there is/was another problem with forgetting news
passwords, the fix for bug 36816 did a very good job in confining it.

I suggest to get a trunk build newer than 20030916 for all having problems with
news passwords. If someone will have a problem with this, I hope we can track it
down more efficiently.

Comment 13

15 years ago
Using 1.6a I encountered this bug however, my newsgroup provider (giganews) has
a cap per month that I exceeded for this month.  When I attempt to access the
newsgroups it tells me that "I've exceeded my cap" but then the newsreader
aspect of mozilla continually asks me, every 10 minutes to enter my
username/password and I have 5 days till my 'cap' clears.

The newsreader program isn't checking the error to see if a user is just over
the cap and continually asking me for what is, valid username access.  Just not
for another 5 days.

Comment 14

15 years ago
What do you mean with cap? How can it be exceeded?

Can you access the newsgroup after enter the correct password or not at all?

Comment 15

15 years ago
I am also seeing this on Mozilla since my ISP switch to Giganews which requires
authentication.

This is apparently the same behavior as bug 91656.

And it is related to bug 206634

Mozilla is handling passwords for news and mail servers backwards from what
other e-mail and newsreaders do, and what users would expect.

The account information should be associated with the properties for the server,
not the individual newsgroups.

In addition, when a login failure occurs, the dialog box does not provide the
options needed to quickly resolve the problem.

In most cases it is a transient error, and their should be an option on the box
to retry now and ot retry later with the last known good options.


The current options for Mozilla force the user to keep reentering their static
account information over and over again when there is a problem with the network
and the server.

If you select cancel on the dialog, the message loading is lost until you delete
the newsgroup and resubscribe to it, or delete the underlying file that is used
to maintain newsgroup context.

As with the POP3 login in problem this is annoying.

However it has the added feature that it causes loss of data if cancel is
selected, and that should qualify it to be marked as a critical bug.

When a username/password pair that has once worked with a news or mail account
gets a failure, it usually does not mean that the username and password are bad
and need to be replaced.  It usually means there is some other problem to be
resolved, and in most cases the problem is transient and will be resovled by a
retry.  If an immediate retry does not fix the problem, then it should be tried
again after a bit of time, and the user notified that it will be tried later.

That is the behavior of Microsoft Outlook Express, and it appears to be a much
better behavior than Mozilla has implemented.


Comment 16

14 years ago
<i>In addition, when a login failure occurs, the dialog box does not provide the
options needed to quickly resolve the problem.</i>

I don't know if you want this as a separate bug or not, but it sounds like the
same problem: I have multiple news servers configured, but when it pops up the
request for a username, it does not identify the news server for which it wants
a password.  In one case, it only does that when the connection limit is reached
and entering a username won't do any good, but naive users will tend to enter
their ISP account info, which is not good.

Comment 17

14 years ago
Mostly similar to comment #9. In addition the problem seems to be, for me, when
I try and access a write-only newsgroup (which just so happens to be essential)
this bug is apparent. If I do not have this newsgroup in the account, the
password manager works fine. But still "looks" like:

Site=news://<NewsServerName>:119/#password , Username=<>
Site=news://<NewsServerName>:119/#username , Username=<>

1. PM needs to be account specific, not server specific.
2. Write-only access still needs to be addressed; it screwes up all
functionality of the client. If this were fixed, I'd completely port over to TBird.
(Reporter)

Comment 18

14 years ago
I have not encountered that problem in 1.7b any more. May I close this bug as fixed?
WFM: Mozilla 1.7b, [...] build 2004040607 (Mozilla Thunderbird 0.5+).  Close it.
(Reporter)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 20

14 years ago
(In reply to comment #19)
> WFM: Mozilla 1.7b, [...] build 2004040607 (Mozilla Thunderbird 0.5+).  Close 
it.

I went ahead and upgraded to the beta versions (Mozilla 1.7b and Mozilla 
Thunderbird 0.5+) and still have the same problem, see comment #17 and comment 
#9. Is there anything I can log and upload in order to help show where the 
problem is located?

This might help a little here:

I'm subscribed to a newsgroup in which one of the subscriptions has "write 
only" properties. If I'm not subscribed to this group, all is well, but when I 
subscribe to this one I get the standard "A News (NNTP) error occurred: no 
permission" both in 1.7b and 0.5+. and when I try and access the other 
subscriptions it allways asks for a user name and password whether I check the 
dialog box or not.
(Reporter)

Comment 21

14 years ago
> I'm subscribed to a newsgroup in which one of the subscriptions has "write 
> only" properties. If I'm not subscribed to this group, all is well, but when I 
> subscribe to this one I get the standard "A News (NNTP) error occurred: no 
> permission" both in 1.7b and 0.5+.

That is not exactly this bug. Maybe You should enter a new bug that is more
specificly related to this write-only issue.

Comment 22

14 years ago
Mozilla 1.7
Mozilla/5.0 (X11; U; OpenVMS AlphaServer_DS10_617_MHz; en-US; rv:1.7) Gecko/20040621


I am still seing this problem.  At the present time, Adelphia requires
authentication to the giganews service, and as I type this, I am getting one of
these pop-up dialogs about once a minute, even though I am not trying to access
the news servers.

I also have an authenticated news access to individual.net and encompasserve.org
and never see this problem from either of these servers.


In addition to being annoying, having popups for getting login information for
mail and news is a security hole, as they can be spoofed by phishing sites to
get the user's login access.  Spoofing the dialog box for news access is
especially easy, since the real username dialog box does not identify what news
server that it is for.

The username and password dialog should be set/changed in the same setup menus
as setting up the server.
Product: MailNews → Core

Comment 23

13 years ago
Malmberg@Encompasserve.org: there's a different bug about the dialog sucking...
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.