can't add bookmark while page is loading in background

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: vlad)

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-aviary1.0PR -
blocking-aviary1.0 -
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
 
(Reporter)

Comment 1

15 years ago
Oops, accidentally hit enter while initially entering the summary. Here goes:
---

OK, so I've been having "Add Bookmark" occasionally silently not work for the
past few months, and finally have found the cause.

I have a page here, full of links to a site that is very unresponsive. If I
middle-click a link to open it in a new tab in the background, selecting add
bookmark from the menu does nothing. It closes the menu but the dialog does not
pop up. If I close the "Loading..." tab, or select it, and then return to the
first, bookmarking works properly.

Also, if I middle click e.g. ten links, I can't bookmark a page unless I close
all ten of them.

The site is now back up, so you may need to setup your own unresponsive service
on port 80 (netcat? perhaps it needs to be before the SYN,ACK? A packet
filtering firewall should work), or find a site that just hangs to test.
Severity: normal → major
Summary: can' → can't add bookmark while page is loading in background

Comment 2

14 years ago
(In reply to comment #0)
>  

I can verify this behaviour for Windows as well, right now I am running Firefox 0.8.

I only have to add that I found this bug to not only occur when the new links
are on unresponsive sites, but whenever they are not fully loaded.

Go to a gallery/graphics site (e.g. deviantart.com, or some photography site, or
wallpaper downloads, ...), and load a lot of links in the background (just
enough so that Firefox is still loading in one or two of them, and then press
CTRL-D. Nothing will happen. Repeat when all tabs with all images are fully
loaded, and it will bring up the bookmarking dialog. Only once though, it will
not miraculously trigger a dialog for the first CTRL-D with some latency or
something.

The OS for this bug should be set to all, since it is obviously affecting Win32
and Linux builds.

Comment 3

14 years ago
Finally I found this bug report. I see the reported behaviour from the
beginning. Steps to reproduce are exactly those reported in comment #2. It
usually needs 2-3 loading tabs for the bookmarking to become non-functional
(neither shortcut nor menu bookmarking works). Perhaps it is not as easy to
reproduce on fast connections but I am very frequently stuck on this when I the
sites I visit are modestly graphics intensive.
OS: Linux → All

Comment 4

14 years ago
IMO, Failing to bookmark a page is something totally unacceptable for a final
release. Nominating for 1.0. 
Flags: blocking1.0?
*** Bug 250998 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Flags: blocking-aviary1.0RC1?
Flags: blocking-aviary1.0PR? → blocking-aviary1.0PR-

Comment 6

14 years ago
Vlad, can you take a look at this please? 
Assignee: firefox → vladimir
+ing for investigation. 
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Not a "blocker"
Flags: blocking-aviary1.0+ → blocking-aviary1.0-

Updated

14 years ago
Blocks: 262161

Updated

14 years ago
No longer blocks: 262161

Comment 9

14 years ago
I think my issue is related, so I won't make a new bugreport yet. Maintainers,
please let me know if it is apropriate to create a new report.

My problem is I cannot open a bookmark in a new tab, if the current tab is in
the middle of a load (/.ed). If I middle-click on my bookmarks toolbar to open
one of my bookmarks in a new tab while a tab is trying to load, the bookmark
gets opened in the tab that is trying to load, not a new one.

Comment 10

14 years ago
needs aviary landing keyword
no it doesn't

Updated

14 years ago
Flags: blocking-aviary1.1?

Updated

13 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-

Comment 12

13 years ago
Shouldnt (Cant type apostrophes any longer due to bug.) this be under bookmarks
component?

Updated

13 years ago
Component: Menus → Bookmarks
QA Contact: bugzilla → bookmarks

Comment 13

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6

I have not been able to reproduce this.  Can someone confirm if this is still a
problem?

Updated

13 years ago
Flags: blocking-aviary2.0?

Comment 14

13 years ago
Can no longer reproduce it too, for a while (maybe more than a month).
WFM 1.5 RC2, resolving, clearing nomination.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary2?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.