advanced address book search: search street/city searches only work address

VERIFIED DUPLICATE of bug 214802

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED DUPLICATE of bug 214802
14 years ago
13 years ago

People

(Reporter: David Harper-Jones, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

If you search the address book based on the "Street" or "City" containing
particular text, a card will only be found if the work address contains that
text; if only the home address contains the text, the card is not found. When
you choose the field you want from the drop-down list, unlike "Work phone" and
"Home phone", "Street" and "City" are presented as being generic, not
specifically work or home.

Related issue (refer to bugs #s 134435, 136309, 184483): the search would be
more flexible if you could search on work address and home address separately.
Really, I'd like to see the ability to search on _every_ field in the address
book: Zip code, Notes, Custom 1, 2, 3, 4, Web address, etc.

Subsidiary issue: the field should have the same name in both the card and the
search dialog: either "Address" in both places (preferably), or "Street" in both.

Reproducible: Always

Steps to Reproduce:
1. make two cards, on with "Broadway" in the home address and "New York" inthe
home city, one with "Broadway"/"New York" in the work address/city.
2. search for (Street contains "Broadway") or (City contains "New York").
3.

Actual Results:  
Only the card with the text in the work address is found.

Expected Results:  
Both cards should be found.

*** This bug has been marked as a duplicate of 214802 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 2

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.