Closed Bug 21505 Opened 20 years ago Closed 20 years ago

startup window size wrong

Categories

(SeaMonkey :: General, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 15555

People

(Reporter: alane, Assigned: danm.moz)

Details

Attachments

(1 file)

Mozilla M11, Red Hat Linux 6.0, kernel 2.2.5, glibc 2.1.*
Installed as mere mortal (under my $HOME, not a system dir, not installed as root)


Each time mozilla is started, the browser window opens up smaller than before.

I can find no cmdline arg to set the X geometry, and no way to save the size. I
can't even find the file (if any) that's saving geometry info; after I run
mozilla and do a find -mtime -1 I pick up nothing.


This isn't a show stopper by any means, but it is really annoying.
It's always starting up as 330x330 for me.  There's an existing bug on window
size (bug 17799), but this is a new regression.
I've found exactly one case where the browser saves window size.  It's when
there's a popup window created with a JS window.open command like

window.open("http://www.mozilla.org/", "name",
"width=800,height=775,toolbar=yes,menubar=yes,status=yes");

and then the window that was opened is closed after the window that opened it.

cc:ing danm.  This bug is in the Browser-General queue.  If it's yours, take it.
Same behavior noted for M12+fullcircle under RH6.1, glibc2.1, kernel
2.2.14pre11.  Window sizes set by javascript window open events are remembered
in the same way as those of manual resize -- that I can think of only resizes
directly resulting from user action (manual resize of window) should be saved
that way.

It's especially annoying inasmuch as advertising windows opened by sites, which
are generally very small, cause a uselessly small browser window on the next
restart.

It'd be really nice, iff it's convenient, to have a preference setting somewhere
to turn the remembering of window sizes off.
Reassigning all of leger's unscreened Browser-General bugs to nobody@mozilla.org
for pre-screening and triage.
Assignee: nobody → danm
Assigning to danm, since he deals with window size issues.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
I don't see the described problem: my linux build remembers the exact size and position
between invocations. Comments following the original, though, make this sound like
bug 15555.


*** This bug has been marked as a duplicate of 15555 ***
Marking Verified as a dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.