Multiple sender addresses (personalities; identities; aliases) for one "account"

RESOLVED DUPLICATE of bug 44863

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 44863
15 years ago
14 years ago

People

(Reporter: Victor Lewis, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)
Build Identifier: 20030723

I receive all of the email that goes to a particular domain.  When I sign up at 
certain web sites or for certain services I use a custom email address, e.g. if 
I were to sign up for at NY Times I might give them an address of 
NYTimes@mydomain.dom.  I will get the email sent to this address and if they 
the address is compromised I will be able to 1) block all mail sent to that 
address and 2) know where the spammers got the address.

From time to time it would be handy to be able to send an email as one of these 
custom addresses (e.g. in the case of a mail list which will only accept email 
from the address with which I signed up).  

So the feature I am requesting is the ability to be able to select from 
multiple sender address for one account when sending email (rather than having 
to create separate account settings for each sender address).

I can think of a few ways this might be accomplished in the UI

1) Simple have an advanced feature that allows free for editing of the sender 
address alla PINE.
2) Allow an account to specify multiple sender addresses which can be chosen 
from a list in the composition window.
3) Get fancy with option one and allow the specification of a regex that will 
define what sender addresses are legal.

Reproducible: Always

Steps to Reproduce:
N/A
(Reporter)

Updated

15 years ago
Summary: Mutiple sender adresses for one "account" → Multiple sender addresses for one "account"

Comment 1

15 years ago
I would recommend either solution no 2) above or/and an account option working
like the message filter options.  ("To - contains - xyz" + "To - doesn't contain
- abc" etc.)  An automatic creation of sender (with regex ?) based on "To"/"CC"
would also be valuable (as I'm also using the reporters method of individual
sender addresses for each receiver).

Comment 2

15 years ago
See this forum for a discussion on this:

http://forums.mozillazine.org/viewtopic.php?t=17617
(Reporter)

Updated

15 years ago
Summary: Multiple sender addresses for one "account" → Multiple sender addresses (personalities; identities) for one "account"
(Reporter)

Updated

15 years ago
Summary: Multiple sender addresses (personalities; identities) for one "account" → Multiple sender addresses (personalities; identities; aliases) for one "account"

Comment 3

15 years ago
I'd like to be able to set a list of predefined addresses to reply as, and be
able to freely edit the from field as well.  Also it would be nice to set the
default from address for replying to messages in certain folders, and be able to
set certain folders to use the to address as the from address when replying.

Comment 4

15 years ago
Should the 'Component' indicator be 'Account Manager' rather than 'Mail Window
Front End' ? I don't know the innards of ThunderBird or MailNews well enough to
make the distinction.

If that is indeed the case, then this bug seems a (near) duplicate of bug 44863
and may instead be a trunk/MailNews issue, notwithstanding the upcoming roadmap
changes.

Updated

15 years ago
QA Contact: asa

Comment 5

15 years ago
I strongly agree to this feature, specially comment #3.

The absence of this feature was the reason for me to switch to an other MUA. I
would like to switch back to TB. Hopefully this feature will be implemented soon.
(Reporter)

Comment 6

15 years ago
A partial, kuldgie, work around for *some* of these issues can be found at
http://forums.mozillazine.org/viewtopic.php?
t=16840&postdays=0&postorder=asc&highlight=identity&start=15#238712

Comment 7

15 years ago
*** Bug 225883 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
> 1) Simple have an advanced feature that allows free for editing of the sender 
> address alla PINE.

Bug 44863

2) Allow an account to specify multiple sender addresses which can be chosen 
from a list in the composition window.

There's another bug about that.

*** This bug has been marked as a duplicate of 44863 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 9

14 years ago
This is feature I found very useful in Outlook as I my ISP account name as my
mail account name. Also I have different usernames at different websites and I
like to beable to send mail from a "username1@mydomain.fsnet.co.uk" or
"username2@mydomain.fsnet.co.uk". In outlook I do this my simply setting up 2
identical accounts but with different names. TB won't let me do this.

I can create a fake incoming pop account but I'd rather not.
You need to log in before you can comment on or make changes to this bug.