Search field icons not being refreshed when choosing New Navigator Window

VERIFIED DUPLICATE of bug 223331

Status

()

Firefox
Toolbars and Customization
VERIFIED DUPLICATE of bug 223331
15 years ago
11 years ago

People

(Reporter: Kevin "Hypoxia" Harris, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When closing any open browser windows and choosing "New->Navigator Window" from
the File menu and then choosing Google or dmoz.org the icon in the search field
remains unchanged unless you actually initiate the search.  Simply choosing one
of the available options does not update the field.  Initating a search forces a
refresh of the icon. Subsequent choices do not get updated either.  Opening a
new window over the existing window using File->New Window does not have the
issue, the icons are redrawn as you select the options.

Reproducible: Always

Steps to Reproduce:
1. Launch FB and close the initial browser window.
2. Select New->Navigator Window from the File menu to open a new browser window.
3. Attempt to change the search service from the default to one of the other
options.

Actual Results:  
The icon in the search field did not change from it's previous condition. If
that condition was the magnifying glass, it remains that icon no matter which
search service you choose.

Expected Results:  
The icon in the search field should have changed to the selected search service.

Note: This does not occur when opening a browser window over an existing browser
window.  It has something to do with choosing a new browser when none are open
using the New hierarchial menu in the File menu.

Comment 1

15 years ago
reporter, were there any error messages in the javascript console?

Comment 2

15 years ago
Confirming this bug on Gecko/20030821 Mozilla Firebird/0.6.1+

No messages in the javascript console.

Could be related to Bug 206933.

Comment 3

15 years ago
cinfirmed with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b)
Gecko/20030903 Firebird/0.6.1+/jtalkington-nightly
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Most likely related to 205708.

Comment 5

14 years ago
Fixed 20031024 Firebird/0.7+ (see bug 223331). Needs to be set as fixed or duped
to that bug.

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 223331 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.