Can't forward some messages with "inline" format

VERIFIED DUPLICATE of bug 65159

Status

Thunderbird
Message Compose Window
VERIFIED DUPLICATE of bug 65159
15 years ago
13 years ago

People

(Reporter: Benjami Villoslada, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

I can't forward some messages with "inline" format.  In my Thunderbird
preferences, composition section, I've selected "Forward messages: Inline". 
Normally this work fine, but in some messages (only some messages) the forward
is in attachment mode. 

When it doesn't work, I select the menú option Message > Forward as > Inline,
but it doesn't work neither: the forwarded message as an attachment.

Inline forwarding is good in some cases: it allows to edit the message to hide
email addresses from spamers (specially when the recipient is a public mailing
list). 


Reproducible: Sometimes

Steps to Reproduce:
1. Work normally with the "Forward messages: Inline" preference
2. Try to forward messages
3. Some messages don't forward inline, are attachments and is not possible to change
4. I can send one of this messages... but as attachment :)
(Reporter)

Comment 1

15 years ago
Note: Thunderbird 0.1 (20030723)

Updated

15 years ago
QA Contact: asa

Comment 2

14 years ago
I can always reproduce this bug using the "Steps to Reproduce" detailed in...

http://bugzilla.mozilla.org/show_bug.cgi?id=239698

Comment 3

14 years ago
This issue present with Thunderbird 0.8-Jul28 (2004) posted on forum by MScott:

See my following post:
Forward-Inline behavior appears to be broken.

With Tbird 0.7, 'forward-inline' would generate a new msg with header details in
TABLE form followed by msg body. Any attachments on forwarded msg would appears
in attachment field.

The correct behavior of 'forward-inline' with 0.8-Jul28 build seems to depend of
presense of attachment, # attachments, text/html, etc.

If msg being forwarded inlcudes NO attachment, the newly created msg is correct
(ie. header info in table). If the msg being forwarded inline includes text with
reply text in body (ie. indented, etc), then newly created msg in NOT correct
(ie. no header info in table exists).

If msg being forwarded includes attachments, the newly created msg does NOT
include previous header details in table.

I'm attempting to figure the exact cause -- but it's not difficult to observe.

This appears to be http://bugzilla.mozilla.org/show_bug.cgi?id=215265

Why was this non-existant in 0.7 and now back with 0.8?? -G

Comment 4

14 years ago
The original report sounds very similar to bug 238638, which was duped to bug 
65159: Some messages (in particular, from the Apple Mail client) have a 
text/enriched portion (which looks a little like HTML when displayed).  These 
parts can be viewed as the main message body, but Moz/TB do not support editing 
text/enriched; so when the forward-inline is activated, the part becomes an 
attachment.  To check this: while viewing the questionable message, select
  View | Message Body As | Plain Text
and then try forwarding -- this should work just fine.  You can also View|Source 
for the message and search for a header line:
  Content-Type: text/enriched [...]
Benjami Villoslada, if that proves to be true, please mark this bug as a 
duplicate of 65159.


GA's Comment 3 sounds like a very different problem, specifically bug 250291.  
That has been fixed, in both Mozilla and TB, and should not be visible in 
current nightlies.

Carl's problem as described in bug 239698 may have a symptom that appears 
similar, but I believe it is a different issue.

Comment 5

14 years ago
No response from reporter, duping.
Benjami Villoslada, if you believe the dupe is in error, feel free to reopen 
this bug and explain why.

*** This bug has been marked as a duplicate of 65159 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

14 years ago
I no longer use Windows (now use GNU/Linux) and I can't test again this bug 
and the possibility of duplicate.  I apologize. 
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.