Closed Bug 215351 Opened 18 years ago Closed 17 years ago

Should be able to attach files with drag and drop

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 113435

People

(Reporter: dalai98, Assigned: mscott)

Details

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: Mozilla Thunderbird 0.1 (20030723)

When drag and dropping files into the message compose window, you expect them 
to attach.  Most local files just put up file:///etc into the message.  
Pictures show up in the message but don't seem to actually send?

Reproducible: Always

Steps to Reproduce:
1.  Drag a file into the message compose body
2.
3.

Actual Results:  
see details

Expected Results:  
Attached the file!
Have you tried dropping on the header pane, instead of the body pane? I find
that the attachments box pops open when you are dragging and hover over the
header pane (in the compose window, that is).

Having said that, dropping a file [from Nautilus] into it doesn't seem to work,
but dropping a mail message from another thunderbird window *does* work. This on
Linux/x86, today's build.
QA Contact: asa
But still, shouldn't it also attach the file if it is dragged into the body??
And also, is this the only bug dealing with this issue? I looked for a similar
bug in the mailnews component, but couldn't find one
Linux drag and drop does not work from Konqueror either (KDE 3.2 Mandrake 10).
Dropping into the body of an HTML composition makes some sense for images, IF 
the message is actually sent as HTML.  (See bug 180997.)

For other file types, dropping into the body just creates a link to a 'related 
part', which is only different from an attachment in that there's a clickable 
link to open it.  (And, again, the file won't actually be included if the 
message is sent as plain text.)  Also, that "file://" link text is just plain 
wrong; see bug 241572.

Note that dropping into the body during plain-text compose is not allowed.

*** This bug has been marked as a duplicate of 113435 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.