bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Thread pane scrolling not smooth and very slow

VERIFIED DUPLICATE of bug 18739

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 18739
19 years ago
7 years ago

People

(Reporter: Ninoschka Baca, Assigned: David Hyatt)

Tracking

({perf})

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 1999121008M12: NT4, Linux/Redhat 6.0, Mac 8.5.1

Overview: Use the vertical scrollbar in the Thread pane and notice that it does
not scroll as smoothly as in 4.7.

Steps to reproduce:
1. Open Mail (POP or IMAP)
2. View a folder with many messages (i.e. 100)
3. Using the vertical scrollbar in the Thread pane, move it up and down

Actual Results: The messages in the thread pane scroll very fast.
Expected Results: It should scroll more smoothly so that it's easier to see the
message headers advancing up or down as in 4.7.

Additional Information:
- View a long message so that the vertical scrollbar appears in the message
pane. Notice that this scrollbar moves more smoothly than the thread pane.
- Bug# 9489 fixed the problem with the scrollbar moving too slow.

Updated

19 years ago
Assignee: phil → hyatt

Comment 1

19 years ago
Reassign to hyatt, cc alecf

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M20

Comment 2

19 years ago
we've pushed the limit on our current scheme, it's really not going to get much
faster until we do random-access enumerators in JS. (which may or may not occur
in 5.0)

Comment 3

19 years ago
Adding perf to keyword field.
Keywords: perf

Updated

19 years ago
Summary: [PERFORMANCE]Thread pane scrolling not smooth → Thread pane scrolling not smooth

Updated

19 years ago
QA Contact: lchiang → nbaca

Comment 4

19 years ago
Seriously, thread pane scrolling isn't expected to get any faster?  Mail won't
really be dogfood until it does.  I have to drag the thumb down to the bottom,
then sit for a few seconds holding the mouse below the bottom arrow waiting for
the scroll to happen, even in optimized builds with fewer than 300 messages in
my inbox.  It's not a matter of smoothness, it's a matter of how long you have
to sit there waiting with the mouse button depressed (RSI city).
Summary: Thread pane scrolling not smooth → Thread pane scrolling not smooth and very slow

Comment 5

19 years ago
to make the next leap in performance we need random access enumerators, which is
a huge architectural change... this isn't just a matter of running quantify and
optimizing more functions.

If you're using the downarrow to scroll the entire  message pane, learn to drag
the thumb - that is pretty fast.

Comment 6

19 years ago
Dragging the thumb is what I'm doing.  It's very slow.

If mail gets smarter about what message it's on, so I don't have to scroll the
thread pane much, that might help the problem (e.g. if it could select and show
the first unread message, keep the selected message in view on resize, scroll to
show new headers as they arrive, etc.).
(Assignee)

Comment 7

19 years ago
*** Bug 30253 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 8

19 years ago

*** This bug has been marked as a duplicate of 18739 ***
(Reporter)

Comment 9

19 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.