Dragging attachment to Explorer window does not save attachment

RESOLVED DUPLICATE of bug 83803

Status

--
major
RESOLVED DUPLICATE of bug 83803
15 years ago
15 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla Thunderbird 0.1 (20030723)

If an attachment is dragged from either the preview pane or a message window to
a Windows Explorer window, the attachment is not saved. This is contrary to what
would be expected.

Whilst it is accepted that 'shortcuts' are often created by Windows itself when
dragging, it is reasonable to expect the user wishes to save the attachment when
doing this (as a point of interest, Outlook works this way, and so migrating
users will expect the same).

It is suggested that this is a regular action performed by users and it is
important that it is fixed to make Thunderbird feel integrated with the Windows
environment.

Reproducible: Always

Steps to Reproduce:
1. Drag attachment from Thunderbird window to Windows Explorer window
Actual Results:  
Create shortcut to file within Thunderbird message store

Expected Results:  
Save the attachment as a file
(Assignee)

Comment 1

15 years ago
can someone dup this for me.

Comment 2

15 years ago
I have (since long) the same problem with Windows XP and the latest Mozilla.

I can drag and drop from a window to the attachment-field in a mail message
(witht the result that the file is added as an attachment), but I cannot do it
the other way round (with the expected result that the attachment is saved as a
document).

Something happens when you do but at least the type of the file is wrong.
Windows things it is some kind of mail-messsage resulting in the windows error

"unable to open this internet shortcut. The protocol "mailbox" does not have a
registered program."

Comment 3

15 years ago
bug 83803 is already assigned to Scott so I dup this one

*** This bug has been marked as a duplicate of 83803 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.