Only the first page of a popup window gets printed.

RESOLVED DUPLICATE of bug 178554

Status

()

Core
Printing: Output
RESOLVED DUPLICATE of bug 178554
14 years ago
14 years ago

People

(Reporter: David Barr, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(7 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030814
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030814

Starting the CSAA home page, I tried to start an "Internet TripTik," as seen in
the second column. When I started I ran into issues that may have been related
to Bug 101190, but upgrading to 1.5b/20030814 appears to have solved that. Now,
with popup blocker on and www.csaa.com set as an Allowed Site, I can get to the
popup window fine.

The problem comes up when I finish building the TripTik and try to print it.

When I get the print window and click on "OK," I will get a progress bar window
as normal. I'll get the message "Printing page 1" and one page worth of blue
progress in the progress bar. Then the progress bar window will go away. Only
the first page will print.

I've tried this with standard printing and printing 2 pages per sheet for no change.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.csaa.com/home/
2. Select "Internet TripTik" from the "Travel" column.
3. Log in with your membership information, or get a test login from AAA. (See
below.)
4. Get the Internet TripTik popup window.
5. Choose and enter starting and ending locations. (Los Angeles, CA, to Chicago,
IL, will work.)
6. Select "Create a TripTik of my trip" and let it run.
7. When the directions come up, click on "Print" at the top right.
8. Click on "Create Print Version." Get a second popup window with the printable
version of the directions.
9. File -> Print
10. Note the progress bar as described above, and note that only page 1 prints.
Actual Results:  
I got page 1 only.

Expected Results:  
I should have got upwards of 15 pages.

Jennifer, 800-228-6339 x3189, support@aaaemail.com, was helping me work through
the blocked popup windows. She's not aware of this problem, but may be willing
to provide a test login to allow Mozilla folks to test this printing weirdness.

I'm not sure if I should rate this as "Normal" or "Major." Printing is a major
feature, but this seems to be a "Normal" level corner of the printing
functionality...

Comment 1

14 years ago
Related to bug 223978?
(Reporter)

Comment 2

14 years ago
This is still showing up in 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6b) Gecko/20031126

Comment 3

14 years ago
David, can you attach the relevant page in this bug report (use the "Create a
New Attachment" link)? Just make sure you don't include any private information.
BTW, how many pages do you see in the print preview?
(Reporter)

Comment 4

14 years ago
Created attachment 145108 [details]
CSAA Main Screen
(Reporter)

Comment 5

14 years ago
Created attachment 145109 [details]
Trip Tik Popup window with first address entered.
(Reporter)

Comment 6

14 years ago
Created attachment 145111 [details]
Two addresses entered, and ready to create the TripTik
(Reporter)

Comment 7

14 years ago
Created attachment 145112 [details]
TripTik is done, and viewable online. Select "Print" tab to create a printable version.
(Reporter)

Comment 8

14 years ago
Created attachment 145113 [details]
Printable version created. Note the dimensions of the scroll bar on the right. This should be a 30+ page document.
(Reporter)

Comment 9

14 years ago
Created attachment 145114 [details]
Choose "Print to PDF" and get this. First page only.
(Reporter)

Comment 10

14 years ago
I'm now at 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040330

and still seeing this.

I'm sorry this took so long to do. I hope this gives you a good visual idea of
what I'm seeing.

What log files/process files (?) can I get that would help?

(Reporter)

Comment 11

14 years ago
Whoops, sorry.

Print preview also only gets the first page.

Comment 12

14 years ago
David, can you please attach the source code of the printable version (or the
actual html page itself). That might tell us if the problem is connected with
the code or not.
(Reporter)

Comment 13

14 years ago
Feh. The printable pop-up window is a frame. Do the debug features having
something that will let me get you the individual frame elements?

+++

<HTML>
<HEAD>
  <META HTTP-EQUIV="Cache-Control" CONTENT="no-cache">
  <META HTTP-EQUIV="pragma" CONTENT="no-cache">
<TITLE>AAA Internet TripTik</TITLE>
</HEAD>
<FRAMESET ROWS="40,*" BORDER=0>
<FRAME NAME="MSG" SRC="/itt/docs/printMsg.html" MARGINHEIGHT="5" MARGINWIDTH="1"
NORESIZE>
</FRAME>
<FRAME NAME="ITS_PRINT" SRC="/itt/docs/marketing/travelmoney.html"
MARGINHEIGHT="1" MARGIN WIDTH="1" NORESIZE>
</FRAME>
<NOFRAMES>
<BODY>
&nbsp;&nbsp;&nbsp;&nbsp;

</BODY>
</NOFRAMES>
</FRAMESET>
</HTML>

+++

Page info gets me information on links and such, which I can pass on if you
think it's useful. I just need a hint on how to get the indvidual frame elements.

(Reporter)

Comment 14

14 years ago
And, just to make things more annoying, the frame elements are "Please wait
while loading..." and an add for AAA Traveler's Checks.

Those two elements show up in a new pop-up once the "Go" command is given to
create a printable page. During the actual appearance the MSG frame switches to
a "Ready to Print" message and a Close Window area. The ITS_PRINT frame holds
the actual map. That's what it looks like, at least.

Does a method exist for me to log the incoming html stream?

Comment 15

14 years ago
(In reply to comment #13)
> Feh. The printable pop-up window is a frame. Do the debug features having
> something that will let me get you the individual frame elements?

Right-click and "This Frame" --> View Frame Source"?
(Reporter)

Comment 16

14 years ago
(In reply to comment #15)
> (In reply to comment #13)
> > Feh. The printable pop-up window is a frame. Do the debug features having
> > something that will let me get you the individual frame elements?
> 
> Right-click and "This Frame" --> View Frame Source"?

Oh, that's too easy... :-p

File to follow...

(Reporter)

Comment 17

14 years ago
Created attachment 145276 [details]
HTML source code of printed frame.
(Reporter)

Comment 18

14 years ago
One page of this gets me to line 10 in the directions.

The last text on the page includes

        content, route practicability or efficiency. User assumes<BR>

on the left and

<TR><TD VALIGN=TOP ALIGN=RIGHT><FONT FACE="ARIAL" SIZE=2><B>10.</TD><TD><FONT
FACE="ARIAL" SIZE=2><B>Turn RIGHT onto I-80-BL. Drive for 0.5 miles.</TD></TR>

on the right.

I did see

<P STYLE="page-break-before:always">&nbsp;

further down, but I can't immediately tell if that's related.

Comment 19

14 years ago

*** This bug has been marked as a duplicate of 178554 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.