Cannot retrieve POP mail with userid containing at-sign (@)

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Benjamin Bridgman, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030516 Mozilla Firebird/0.6

Lycos.co.uk allow users to retrieve mail via their POP server, and send mail via
their SMTP server. I can retrieve Lycos.co.uk mail, but I cannot send it. This
happens not only in Thunderbird, but also in Mozilla Mail, Netscape 6/7 Mail and
all other mail clients that use the Gecko engine. The passwords supplied were
correct, but it might be because the username you have to use for connecting to
Lycos.co.uk Mail is in the format of "hartlandcat@lycos.co.uk" instead of just
"hartlandcat".

Lycos.co.uk Mail works fine in most other email clients. I have managed to get
it to work in Outlook Express, Eudora and Foxmail.

Reproducible: Always

Steps to Reproduce:
1. Set up a Lycos.co.uk Mail account in some form of Gecko-based email client
2. Click Compose (or Reply) to write a new message from that account
3. Press send
4. Enter your password

Actual Results:  
After typing in your password in the dialogue box and pressing OK, the box keeps
coming back repeatedly and asking for the password again -- the message does not
get sent.

Expected Results:  
The password should have been accepted and the email sent.

The theme does not seem to affect this bug.

Comment 1

15 years ago
Maybe adding this to your user.js may help:
user_pref("mail.allow_at_sign_in_user_name", true);

But that's just a guess, I think it would be helpful to let Thunderbird create a
SMTP log (details:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#smtp) and post it
here.

Updated

15 years ago
QA Contact: asa

Comment 2

14 years ago
xref bug 212937.

(In reply to comment #1)
> Maybe adding this to your user.js may help:
> user_pref("mail.allow_at_sign_in_user_name", true);

According to bug 245606 comment 4, this (?) preference has been removed.

Benjamin Bridgman, are you still having this problem?
Summary: Cannot send lycos.co.uk email → Cannot retrieve POP mail with userid containing at-sign (@)

Comment 3

14 years ago
Marking WFM - no reporter response.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.