Dropping bookmark item onto scrolling Bookmarks Manager end disables Bookmarks Manager

RESOLVED DUPLICATE of bug 210719

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 210719
15 years ago
8 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030818
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030818

When you drag an bookmark item in Bookmarks Manager to the lower end of
Bookmarks Manager box where status bar of Bookmarks Manager is located,
Bookmarks Manager starts scrolling down to show items stored in lower part of
Bookmarks Manager. In the middle of this auto-scrolling, drop the dragged item
onto the Bookmarks Manager end (i.e. onto near Bookmarks Manager status bar) and
it never stops scrolling until it reaches dead end. Then close Bookmarks Manager
and you can't open it again, and close Mozilla and you see Mozilla process stays
on process list until you kill it manually (hence you can't restart Mozilla
because of lock unless you kill it)

Reproducible: Always

Steps to Reproduce:
1. Drag an bookmark item in Bookmarks Manager to the lower end of Bookmarks
Manager box where status bar of Bookmarks Manager is located
2. Bookmarks Manager scrolls down
3. Drop the dragged item onto the Bookmarks Manager end (i.e. onto near
Bookmarks Manager status bar)
Actual Results:  
It never stops scrolling

Expected Results:  
Dropping item stops auto-scrolling.

I got this on Firebird too.
(Reporter)

Comment 1

14 years ago
When I exit after step 3. with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.7a) Gecko/20040214 Firefox/0.8, it crashed.
Component: Bookmarks → Bookmarks
Product: Browser → Firefox
Version: Trunk → unspecified

Comment 2

14 years ago
Luke Nowak - 25 February 2004

I have replicated this bug with Firefox 0.8 on Windows XP Professional. The bug 
can be seen when you are auto-scrolling up and down.

Additionally, when I try to close the bookmark manager after replicating the 
bug, but before closing the browser, the program crashes. If after replicating 
the bug I try to close the browser before the bookmark manager, the program 
seems to exit fine when the bookmark manager is closed, but doesn't terminate 
properly.

Comment 3

14 years ago
(Manan Pancholi & Oben Yapar) 26 February 2004

Successfully able to replicate the bug on Windows 2000 Professional with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Also, the bug can be replicated by auto-scrolling up in Bookmarks Manager when
we drag a bookmarks item to upper side of the Bookmarks Manager's window.
Moreover, after replicating the bug, if we close the bookmarks manager, we are
able to debug the program.

Comment 4

14 years ago
Attempted on Windows XP Professional with a fresh install of Firefox 0.8

When moving over the area that causes Bookmarks Manager to start scrolling, the
mouse pointer turns into a prohibitted sign. The bug occurs when trying to drop
a bookmark here while scrolling. I don't believe that it is expected to be able
to drop a bookmark here. Also, I am able to stop the auto-scrolling and the
impending error by clicking on a bookmark and dragging and dropping it somewhere
"legal".

When replicating this bug in consecutive attempts, I observed that the error
produced seems to be random. In one instance, Firefox will crash. In the other,
I was able to exit out of Bookmarks Manager and Firefox without a crash, but the
program was never terminated and remained as a running process in Windows
Taskmanager.

It would seem that Firefox does not close properly because it gets stuck in the
process of auto-scrolling and can not stop by itslf without the user.

Comment 5

14 years ago
Bug # 216617

(Pratik Patel) 2 / 27 / 04
Platform : Windows XP
Build : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 
Firefox/0.8

I was able to replicate this bug. But I would suggest a more clearer set of 
steps for replication of the bug :-

1. Go to “Bookmarks” menu and click on “Manage Bookmarks”.
2. Expand all the folders of bookmarks so the vertical scroll bar is visible. 
Alternative step : you can also resize the “Bookmarks Manager” window to a 
smaller size until the vertical scroll bar is visible.
3. Drag a bookmark item in the list to the bottom of the list. The list should 
automatically scroll down as you move the item downwards.
4. While the list is automatically scrolling down, drop the bookmark item near 
the end of the list. 

A follow-up test that would be handy for this bug would be to test to see if 
the bug exists when you try to move a bookmark item to the top of the list. 
Testing for this bug might help the developer narrow down on the fix for the 
bug. It could be easier for the developer to figure out if the bug has to do 
with general navigation in a list.

Updated

14 years ago
QA Contact: chrispetersen → mconnor

Comment 6

14 years ago
I can reproduce the bug on both
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040329
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040329 Firefox/0.8+

However this bug seems to be a dupe of bug 210719.
(Reporter)

Comment 7

14 years ago
OK, moving...

*** This bug has been marked as a duplicate of 210719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 8

14 years ago
*** Bug 240295 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.