vertical 3 pane view resizes preview window to fit long e-mail address

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: George Deka, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

282.43 KB, application/x-zip-compressed
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030811 Mozilla Firebird/0.6.1+
Build Identifier: Mozilla Thunderbird 0.2a (20030807)

When changing from reading one email to another it will sometimes change the
size of the preview window depending on the email you are switching from and to.

Reproducible: Sometimes

Steps to Reproduce:
1. Select a email
2. change to another email
3.

Actual Results:  
The size of the preview pane altered

Expected Results:  
kept the size that i had set

Comment 1

15 years ago
This works for me. Is this still an issue for you? Can you attach a screenshot?
(Reporter)

Comment 2

15 years ago
Created attachment 131236 [details]
Screenshots of error

Here are the screeshots you requested, i upgraded to v0.2 to make sure the
error was still occouring.

Comment 3

15 years ago
Does this happend with the default skin?
(Reporter)

Comment 4

15 years ago
I am using the default skin, the reason why it looks different is because i am 
using a visual style on windows.

Updated

15 years ago
QA Contact: asa

Comment 5

13 years ago
This used to happen to me a lot with 0.9. I've just upgraded to 1.0 and it still
happens, although with only a few messages. (What happens is that the message
preview pane will widen, squishing the folder message list until the Subject and
Sender columns are just slightly wider than their labels.) Once I move on to the
next message, the proper pane size is restored.

Comment 6

13 years ago
I use version 1.0, I it happens to me also. It can be reproduced by sending a
message to yourself and someone with a very long (fake) email address. The very
long emailaddress (~80 characters) shows up in the header of the received mail,
and pushed the left side of the preview pane aside.

Comment 7

13 years ago
This also happens if there is an attachment (the case I tested was a forwarded
message) with a very long name. The preview pane expands to fit the attachment
name, making the message list very narrow. (TB 1.0)

Comment 8

13 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b)
Gecko/20030811 Mozilla Firebird/0.6.1+
> Build Identifier: Mozilla Thunderbird 0.2a (20030807)
> 
> When changing from reading one email to another it will sometimes change the
> size of the preview window depending on the email you are switching from and to.
> 
> Reproducible: Sometimes
> 
> Steps to Reproduce:
> 1. Select a email
> 2. change to another email
> 3.
> 
> Actual Results:  
> The size of the preview pane altered
> 
> Expected Results:  
> kept the size that i had set

I have the same problem. Using version 1.0.2.

Comment 9

13 years ago
Same occurs for me on Linux using build version 1.0.7-1.1.fc4 (20050929).  
Should bug be set to OS: All?

Comment 10

11 years ago
(In reply to comment #6)
> I use version 1.0, I it happens to me also. It can be reproduced by sending a
> message to yourself and someone with a very long (fake) email address. The very
> long emailaddress (~80 characters) shows up in the header of the received mail,
> and pushed the left side of the preview pane aside.

I don't see this behavior with long addresses nor long subject - TB truncates the preview pane header on the right side. Attachments do affect the width, but reporter isn't complaining about that.

WFM windows version 2 beta 2 (20070124) and version 3 alpha 1 (20070109)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
OS: Windows XP → All
Hardware: PC → All
Resolution: --- → WORKSFORME
Summary: vertical 3 pane view resizes preview window → vertical 3 pane view resizes preview window to fit long e-mail address
Version: unspecified → 0.9
You need to log in before you can comment on or make changes to this bug.