Add support for rewrap paragraph in mail compose/reply

RESOLVED DUPLICATE of bug 187997

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 187997
15 years ago
14 years ago

People

(Reporter: Simon Billingsley, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla Thunderbird 0.2a (20030813)

When composing a reply to an email with lots of > and >> entries, it would be
nice to be able to rewrap individual paragraphs that have messed up.  So could a
pop-up menu (right click) entry be added to rewrap the text.  This should have a
selection mode context - so that if it is chosen when text has been selected it
only rewraps that selection.

Reproducible: Always

Steps to Reproduce:
1. Reply to an email with > or >> lines
2. Select a paragraph
3. Select rewrap from the Edit menu

Actual Results:  
Whole message is rewrapped, not individual paragraph - after clicking
Edit->Rewrap menu entry.

Expected Results:  
Individual paragraph is rewrapped after clicking 'pop-up' menu entry.

Updated

15 years ago
QA Contact: asa

Comment 1

14 years ago
I'd vote for this one, too. My old mailer (The Bat!) supported marking a
paragraph and pressing a hotkey, then the paragraph got rewrapped. If the
paragraph was quoted, quoting signs were fixed as well. This is a very good
feature, so PLEASE include it.

Comment 2

14 years ago
Is this related/a duplicate of 228315

The basic request here seems to be that rewrap should understand what it is
wrapping (e.g. an already quoted block, a coloured block, a paragraph) and
should preserve that when performing the wrapping.

I'm most concerned about the preservation of quotes when rewrapping 1 or more
long lines. At the moment, if I do the following.

1. select one or more long lines that are quoted in the compose window
2. click on edit/rewrap

The line is rewrapped but the quote symbol isn't duplicated on the extra lines.

This is asbug more than an enhancement request I think.

Comment 3

14 years ago
I don't understand why this bug was opened.  Support for rewrapping a selected 
paragraph has been in place since before TB ever got started.  Rewrap *does* 
maintain quote marks, so long as they are properly formatted.

In plain-text composition, you cannot just paste in a bunch of lines that have 
already been prefixed with '>' and have those treated as a quote; you need to 
use Paste As Quotation, or to actually reply to a message, to get the lines 
handled as quotes.  But once they *are* recognized as quotes, they can be 
selectively rewrapped.  Not especially well, but that's bug 187997.

In HTML composition, rewrap on a quoted block transforms it in ways that I think 
are senseless; that's bug 249082.

Simon Billingsley: do you have any reason not to mark this bug Invalid?
(Reporter)

Comment 4

14 years ago
I agree that this is a duplicate of Mozilla MailNews bug 187997
I can't find the original email that prompted this bug, but reading the
duplicate bug I can see that I am not the only one to experience this problem.


*** This bug has been marked as a duplicate of 187997 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.