Closed Bug 216997 Opened 17 years ago Closed 11 years ago

hidden fixed div causes visible absolute div to be displayed incorrectly when scrolling

Categories

(Core :: Web Painting, defect)

PowerPC
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmartin2004+mozilla, Assigned: roc)

References

()

Details

(Keywords: testcase, Whiteboard: closeme 2009-08-01)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020623 Debian/1.2.5-0.woody.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030721, Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4) Gecko/20030529, Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3.1) Gecko/20030425

When the page is scrolled, the part of the main part (position:absolute) of the
page that would be obscured by a popup window (position: fixed) if the popup was
visible is scrolled differently than the rest of the main part, causing text and
images not to align properly.


Reproducible: Always

Steps to Reproduce:
1.Load the URL.
2.Scroll.

Actual Results:  
Scrolled areas should be displayed properly.

Expected Results:  
Some regions of the screen do not display the scrolled areas correctly.

The problem can be reproduced with all three versions of Mozilla mentioned
above. With Mozilla 1.3.1, the problem can be avoided by setting the visibility
of the popup window to 'hidden' with a script, for example using <body
onload="...">, even though the visibility is already 'hidden' according to the
style sheet (this method is used in the URL above).

On Windows (Mozilla 1.4) and with Mozilla 1.2 on MacOS 9, the text does not
align while scrolling, but as soon as scrolling stops, the text realigns.

No such problems using Mozilla 1.0 on Debian/GNU Linux Woody.
Keywords: testcase
->views, but perhaps a duplicate
Assignee: dbaron → roc+moz
Component: Style System → Layout: View Rendering
Whiteboard: DUPEME
This works for me.

Which is surprising, since it is a duplicate.

*** This bug has been marked as a duplicate of 203439 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
I'm not sure whether this is a real duplicate of 203439. 203439 talks about 
slow scrolling, but on the Mac, we actually have real screen distortion. 
 
I just verified the bug on MacOS X with Mozilla 1.7 and Firefox 0.9. The 
problem still exists. 
 
Camino 0.8 does not exhibit this problem. Does it use a different rendering 
engine? 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Do you still see this problem using Firefox 3.5?  Please update the bug, and close/alter bug if appropriate.
Whiteboard: DUPEME → closeme 2009-08-01
No reply, INCO. Please reopen if you are seeing this in Firefox 3.5.2 or later in Firefox safe mode and a new profile with the latest plugins.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Profiles
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago11 years ago
Resolution: --- → INCOMPLETE
Let's call it WORKSFORME then, this certainly isn't INCOMPLETE, since the bug contains a clear and concise testcase. Anyway, this might haven been fixed by bug 352093.
Resolution: INCOMPLETE → WORKSFORME
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.