View Message Threaded results in misthreading

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
14 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
As part of the fix for bug 72493, the menu item  View | Message | Threaded   was 
(re)implemented.

Selecting this item to thread the messages can result in a grossly misthreaded 
pane (screenshots to follow).  Some messages disappear entirely from the 
listing, replaced by duplicates of others that have been shifted into threads.
Also, in some cases, the threading icon itself is indented like a subitem in a 
thread.

On deselecting the menu item, the disappeared items remain disappeared, and the 
duplicated items remain duplicated.

Original content of the folder can be re-established by simply shifting the view 
away from, then back, to the folder; if threaded, the threading is correct as 
well.

Clicking on the Thread column header, or  View | Sort by | Thread, does not 
result in this bogus threading.

Even for a static folder, the results of going from a (good) flat view to the 
bogus threaded view are not always identical; the erroneous display is 
different, as will be seen in the screenshots.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030820
(Reporter)

Comment 1

15 years ago
Created attachment 130248 [details]
Original view (flat sort by date)
(Reporter)

Comment 2

15 years ago
Created attachment 130249 [details]
After  View|Sort by|Thread

This is with the threads all expanded, the original display shows the threads
collapsed; and the sort order is Order Received rather than by date.  However,
the messages are correctly threaded, which is the point.
(Reporter)

Comment 3

15 years ago
Created attachment 130250 [details]
View after   View|Message|Threaded  (take 1)
(Reporter)

Comment 4

15 years ago
Created attachment 130251 [details]
View after View|Message|Threaded (take 2)

Both this and the previous attachment were generated after selecting
View|Message|Threaded from a good, flat, by-date view.	Note the differences
between the two; the second one, in particular, exhibits the disappeared items
and the indented thread-twisty.
(Assignee)

Comment 5

15 years ago
taking, so it's just the menu item that produces the problem...
Assignee: sspitzer → bienvenu
(Reporter)

Comment 6

15 years ago
If that was a queston:  Yes, just the  View|Messages|Threaded  item.   
View|SortBy|Thread  does not cause the problem.

Possibly related to bug 194444, which may itself be related to, or a dupe of, 
bug 178999.
(Assignee)

Comment 7

15 years ago
Created attachment 130477 [details] [diff] [review]
proposed fix

this should fix it. I believe the other bugs mentioned are not related.
(Assignee)

Updated

15 years ago
Attachment #130477 - Flags: superreview?(scott)

Updated

15 years ago
Attachment #130477 - Flags: superreview?(scott) → superreview+
Comment on attachment 130477 [details] [diff] [review]
proposed fix

r/a=sspitzer for 1.5 beta (or 1.5 final)
Attachment #130477 - Flags: review+
Attachment #130477 - Flags: approval1.5b+
(Assignee)

Comment 9

15 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

15 years ago
I can verify that the threading is now correct.  There is an additional part of 
this which is still an issue; I can open that in another bug, or reopen this 
one, as desired:

Take this flat set of messages (by date):
   SubjA        Bob     21-May 9:15
   SubjB        Bob     21-May 10:30
   Re: SubjA    Carl    21-May 10:45
   Re: SubjA    Bob     21-May 10:50
   Re: SubjB    Sue     21-May 10:55

Use   View | Messages | Threaded:
   SubjA          Bob     21-May 9:15
     Re: SubjA    Carl    21-May 10:45
       Re: SubjA  Bob     21-May 10:50
   SubjB          Bob     21-May 10:30
     Re: SubjB    Sue     21-May 10:55

Then select View | Messages | Threaded again, to unthread:
   SubjA        Bob     21-May 9:15
   Re: SubjA    Carl    21-May 10:45
   Re: SubjA    Bob     21-May 10:50
   SubjB        Bob     21-May 10:30
   Re: SubjB    Sue     21-May 10:55

Altho Date is still indicated as the sort order, the messages have not been 
resorted into a flat-by-date order.  Clicking the Date column reverses the 
order, but does not resort.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030828
(Reporter)

Comment 11

15 years ago
David Bienvenu, did you want that symptom described in comment 10 as a separate 
bug, or should I reopen this?
(Assignee)

Comment 12

15 years ago
Mike, please file a new bug on me for that problem, thx.
(Reporter)

Comment 13

15 years ago
Verifying fixed; symptom from comment 10 now bug 218656.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.