Closed Bug 217150 Opened 18 years ago Closed 18 years ago

Firebird can't open .eml files or handle message/rfc822 MIME-type

Categories

(Firefox :: General, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED INVALID

People

(Reporter: jo.hermans, Assigned: bugzilla)

References

Details

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5a) Gecko/20030715
Mozilla Firebird/0.6
Mac OS X 10.2.6

(see also bug 217118)

Seamonkey could write files from the mailer, and they could be read in the
browser. The same thing for everything with the message/rfc822 (for instance
http://www.omnifarious.org/~hopper/bad.822 as mentioned in bug 217118). This was
easy because Semonkey was both a browser and a mailer.

With Firebird, it's a bit more difficult. It doesn't know how to parse
message/rfc822 anymore, so it tells you to open it with an external application.
 But Thunderbird isn't the default handler for this MIME-type (bug 217149) yet.

I don't think that we ever want to open the .eml files directly in Firebird (we
would have to including the parser-routines from the mailer), but rfc822 could
be routed to Thunderbird if bug 217149 is solved.
What exactly is the bug here? This is functionality which should be handled by
the mail-client and not the browser. Therefore the bug you filed in Thunderbird
is valid, this one is not.

As you say, when bug 217149 is fixed in TB, it (or another mail application)
will pick up these file-extensions and everything will be fine.

-> INVALID. There's no need to duplicate this bug for firebird.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
verified.
Status: RESOLVED → VERIFIED
*** Bug 260702 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.