Closed Bug 217185 Opened 16 years ago Closed 2 years ago

Run Thunderbird in background (invisibly) to check for new mail

Categories

(Thunderbird :: Account Manager, enhancement)

x86
All
enhancement
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 208923

People

(Reporter: SkewerMZ, Unassigned)

Details

I think most users would appreciate the option to run Thunderbird in the
background (no taskbar icon, no window) to check for new messages automatically.
The user could then see a notification if there are new messages and open
Thunderbird to access them. This is an obstacle to converting full Mozilla users
because full Mozilla will check for new mail in the background if you only have
a browser window open.
QA Contact: asa
Dupe of bug 208923 ?
If this bug's main point is that TB should be running invisibly, it's not a 
dupe; but then, I would recommend WontFix.  Personally, I'd rather have an 
always-visible taskbar icon that changed state when new mail arrived, as 
suggested at bug 208923.

One problem with running invisibly is that for platforms other than Windows and 
Mac, there is no visible notification, so there would be no means of getting to 
the program.
Summary: Run Thunderbird in background to check for new mail automatically → Run Thunderbird in background (invisibly) to check for new mail
My recommendation is different: 

Have a a different app (another exe), much smaller that performs the only function to run in bg, stay in tray and periodically check for new mail, notify and if clicked, to start the main app. 

I really don't appreciate having a large app like TB stay in bg/tray just to check for mail, or keep TB open all the time. 

I believe NS4 had such a small companion.
QA Contact: account-manager
Assignee: mscott → nobody
> I believe NS4 had such a small companion.

I don't recall that it did.


> This is an obstacle to converting full Mozilla users because full Mozilla will check for new mail in the background if you only have a browser window open.

Here you are referring to the "suite", which can be true - iirc you don't have the mail UI open for mail to be checked.


> Have a a different app (another exe), much smaller that performs the only function to run in bg, stay in tray and periodically check for new mail, notify and if clicked, to start the main app

I don't think we'd ever do this - so if this is you main requirement then this bug is WONTFIX. But if we did, it would almost certainly significant elements of what's needed for bug 208923 - so duping
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 208923
You need to log in before you can comment on or make changes to this bug.