Download manager log causes slow dialog GUI changes

RESOLVED DUPLICATE of bug 159107

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 159107
15 years ago
13 years ago

People

(Reporter: pastyboyz, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624

The problem is the download manager log does not have an option to either
automaticly delete the log file on exit or every X days, and this causes the log
file to grow to very size, and eventauly slow down the GUI dialogs that allow
saving and statusing a download. We need and option for the system to
automatically clear this file so the user does not have to remember to clear
this out.

Reproducible: Always

Steps to Reproduce:
1. Save 500 to 1000 files without clearing the download log
2.
3.

Actual Results:  
Very slow GUI for save and status downloading of files

Expected Results:  
The download log should have never grown to that ponderous size and cause that
problem in the first place.

default theme

Comment 1

15 years ago
Related bugs:
bug 159107 about the problem,
bug 132755, bug 182045, and bug 157680 about the clearing

IMHO you could dupe it against some of the given bugs.

*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.