make didn't finish building Firebird.

RESOLVED DUPLICATE of bug 217409

Status

--
major
RESOLVED DUPLICATE of bug 217409
16 years ago
19 days ago

People

(Reporter: ZookQValem, Assigned: bryner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: make error -- Makefile does not exist in 'mozilla/toolkit/components/history/public'

make didn't finish building Firebird.

Reproducible: Always

Steps to Reproduce:
1. Follow similiar instruction from Gemal at http://gemal.dk/mozilla/build.html
2. Use different .mozconfig setup (Not the same coding at Gemal's website).  
Look at Comment #1 down below for the .mozconfig setup.
3. Build it!

Actual Results:  
make stopped building Firebird with an error.

Expected Results:  
Should successfully build Firebird.

make error is possiblity due to an incorrect coding in configure or other 
Makefile.  Blocker doesn't seem to be a correct Severity setting but I put it 
down anyway because Mozilla/Firebird won't build successfully, therefore fot 
the description 'Blocker: This bug prevents you from testing or developing 
Mozilla.'
(Reporter)

Comment 1

16 years ago
## ----------------------
## .mozconfig script ----
## ----------------------

CC=gcc
CXX=g++
CPP=cpp
AS=as
LD=ld
ac_add_options --disable-accessibility
ac_add_options --disable-activex
ac_add_options --disable-ldap
ac_add_options --disable-tests
ac_add_options --enable-debug
ac_add_options --disable-debugger-info-modules
ac_add_options --disable-composer
ac_add_options --disable-mailnews
export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
(Reporter)

Comment 2

16 years ago
Created attachment 130733 [details]
build.log -- Log file of all output when building Firebird.

See attachment of a build.log for compiler's output when building Firebird.
It's being Winzipped because it's too big for bugzilla.
(Reporter)

Comment 3

16 years ago
The make error is due to no Makefile in the 
filepath 'mozilla/toolkit/components/history/public'.  So, it is a possible 
coding error in .configure or from other Makefile.  Still searching for the 
offending Makefile but go ahead and jump in to help out.  Let's get this 
working.
--enable-crypto is a required option to build Firebird now. Make sure you have
it in your mozconfig.

*** This bug has been marked as a duplicate of 217409 ***

*** This bug has been marked as a duplicate of 217409 ***
Severity: blocker → major
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 6

16 years ago
Thanks for your help.  Okay, I'll include that prefix option you're referring 
to.  One more question.  Care to fill me in on where can I find the 
documentation or something about detecting whether the tree is bonk or not.  
Might be useful to have this knowledge.  Thanks.
(Assignee)

Comment 7

16 years ago
It also looks like you didn't have MOZ_PHOENIX=1 (or didn't have the mozconfig
in place) when you _pulled_ the tree.  So, it didn't pull mozilla/browser and
mozilla/toolkit.
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.