Closed Bug 218146 Opened 20 years ago Closed 18 years ago

switch tabs onmousedown instead of onclick

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 295721

People

(Reporter: jruderman, Assigned: bugzilla)

References

Details

(Keywords: perf)

Attachments

(1 file)

Steps to reproduce:
1. Mouse down on a non-active browser tab.
2. Mouse up somewhere else.

Result: After step 2, the tab becomes active.

Expected: 
a) After step 1, the tab becomes active (conflicts with bug 113934).
or
b) After step 2, nothing happens.
QA Contact: asa
The onclick at
http://lxr.mozilla.org/mozilla/source/toolkit/content/widgets/tabbox.xml#494 is
being called.  This is an Events problem... maybe bug 185924.
This patch brings Firebird in line with other Windows apps (Wordpad, Word,
Windows Explorer, Internet Explorer, mIRC).  It affects both tabbed browser
windows and tabbed dialogs such as the cookie manager.

This patch might cause strange visual effects with themes that have :active
styles for tabs.  But I couldn't find any Firebird themes with :active styles
for tabs.
Attachment #133730 - Flags: review?(blake)
Jesse, I am not familiar with Windows. Are you referring the the options dialogs
in Windows? IE, wordpad and word have no tabs as far as I know.
Yes, I'm referring to options dialogs in those programs.

Btw, mIRC also has a "switchbar" that acts like a tab bar and works onmousedown.
One thing I really like about the current tabbed browser implementation is that
I can right-click and select 'Close' without changing the active tab. Does this
patch change that?
No.  The patch keeps button="0", so it still only applies to the left mouse
button.  (Hmm, this patch might not be great for Mac users with one-button mice.)
I'm all gung-ho on consistency but I don't really see a compelling reason to
make this change.  You don't really gain anything and you lose the ability to
change your mind...
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → WONTFIX
Attachment #133730 - Flags: review?(firefox) → review-
This bug report is invalid as filed (summary: "mousedown on tab and drag out
still switches to tab").  I see that incorrect behavior because of the following
in my userChrome.css:

.tabbrowser-tabs tab { -moz-opacity: .5 !important; }
.tabbrowser-tabs tab[selected="true"] {-moz-opacity: 1 !important;}

I have filed bug 234399 with an HTML testcase.

Changing summary to what Blake wontfixed.  (I disagree: I think 50ms faster
response and consistency with other Windows programs are slightly more important
that being able to change your mind during a click.)
Severity: minor → enhancement
Summary: mousedown on tab and drag out still switches to tab → switch tabs onmousedown instead of onclick
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Fixed elsewhere.  Reopening from WONTFIX and duping.

*** This bug has been marked as a duplicate of 295721 ***
Status: REOPENED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Keywords: perf
You need to log in before you can comment on or make changes to this bug.