Closed Bug 218442 Opened 21 years ago Closed 21 years ago

Middle mouse on compose-window's scrollbar pastes clipboard content

Categories

(MailNews Core :: Composition, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 70698

People

(Reporter: gbrinkmann, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030827

If you compose a longer mail and click into the vertical scrollbar-area above or
below the scroll bar, the content of the clipboard is pasted at the top of the mail.

Reproducible: Always

Steps to Reproduce:
1. compose a long mail so that the vertical scrollbar occurs
2. scroll down (or up) to the bottom (or the top) of the mailtext
3. mark some text with the mouse
4. middle-click above (or below) the scroll bar

Actual Results:  
1. The marked text is pasted as the first characters into the mail text.
2. The window always scrolls to the top.


Expected Results:  
Scroll to the position where you middle clicked on the scroller without pasting.
resolving as dup of bug 70698 (by way of dup bug 82513)

*** This bug has been marked as a duplicate of 70698 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.