"Close Other Tabs" Needs a Confirmation Dialog

RESOLVED DUPLICATE of bug 242844

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 242844
15 years ago
14 years ago

People

(Reporter: Peter Lairo, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030905 Firebird/0.6.1+ StumbleUpon/1.84
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030905 Firebird/0.6.1+ StumbleUpon/1.84

"Close Other Tabs" Needs a Confirmation Dialog

This is FB's version of bug 191578. A similar functionality already exists for
closing windows that have multiple tabs: bug 108973

PS. How are bugs handled that exist in both mozilla and firebird? It seems silly
to have to file two bugs.

Reproducible: Always

Steps to Reproduce:
1. open multiple tabs
2. selct "Close other tabs" from context menu of any one tab

Actual Results:  
other tabs are cloesed without warning the user.

Expected Results:  
Dialog appears giving the user a second chance to avoid potential dataloss.

+- Confirm Close Other Tabs ---------------------------+
|                                                      |
| You are about to close [4] other tabs. Proceed?      |
|                                                      |
|  [x] Warn me about closing other tabs in the future. |
|                                                      |
|         [ Close Other Tabs ]    [ Cancel ]           |
+------------------------------------------------------+

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 189888 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Bug 189888 is about closing a WINDOW with multiple tabs, this bug is about
closing all OTHER TABS. UNduping.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
this is probably wontfix since more people use Close button then Close other tabs 

but the Close button people get no warning so why should the rarer Close other 
tabs people get a warning?
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

15 years ago
Bug 189888 was wontfixed in February, BEFORE this functionality was implemented
and shown USEFUL in Mozilla. I've requested that that poor decision be
reconsidered in bug 189888. Reopening this bug until that bug is reconsidered by
a senior developer (e.g., ASA).

Reasons why this bug is useful: 

- No code bloat (a simple dialog)
- No UI bloat (never see it unless triggered, can turn off forever)
- Prevents dataloss
- We've now seen how useful this feature is in Mozilla (bug 108973).

I see no good reason to not fix this important bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Updated

15 years ago
Keywords: dataloss

Comment 5

15 years ago
I think it would be good to fix this bug.
I happened to close my tabs accidentally (close tab and close other tabs are 
neighbor items in a menu) and this is annoying.
I never use close other tabs and if I do there is no problem for me to
just confirm what I'm doing.

Comment 6

15 years ago
- crude function
- 'File - Exit' is intended to close all windows immediately
- No dataloss (You can still use 'Go' menu after reboot)
- Mozilla != Mozilla Firebird

Use "Tabbrowser Extensions." You'll see a Confirmation Dialog.
http://texturizer.net/firebird/extensions/#Tabbrowser%20Extensions
http://white.sakura.ne.jp/~piro/xul/_tabextensions.html.en#history
> 1.5.20021108-20021228
 
-> wontfix
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Keywords: dataloss
Resolution: --- → WONTFIX
(Reporter)

Comment 7

15 years ago
> - crude function

I see nothing crude about a simple dialog that prevents dataloss and can easily
be disabled.

> - 'File - Exit' is intended to close all windows immediately

This bug has nothing to do with "File | Exit". It is always a bad thing to
irreversibly lose data, especially if the user can't see (non-selected tabs)
what will be lost.

> - No dataloss (You can still use 'Go' menu after reboot)

What does the GO menu do to retrieve lost forms that may have bee partially
filled in? Digging around in History is too cumbersome and doesn't restore a
meticulously assembled tab-group of search results.

- Mozilla != Mozilla Firebird

So? That's no reason to make Firebird insecure for users who depend on
dataloss-preventing dialogs (like "delete-confirmations").

<sigh>

Comment 8

14 years ago
verified wontfix
Status: RESOLVED → VERIFIED
Reopneing, duping to bug 242844
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---

*** This bug has been marked as a duplicate of 242844 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.