Closed Bug 189888 Opened 20 years ago Closed 19 years ago

Show a Warning Dialog when Close a Window that has Multiple Tabs

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 68215

People

(Reporter: eavis, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20030120 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20030120 Phoenix/0.5

(There is already a bug #108973 against Mozilla for this, but because it is a UI
issue I am assuming that it would need to be done separately for Phoenix.  If
not, I apologize and please mark as duplicate.)

There should be a warning when closing a window which contains multiple tabs.

Reproducible: Always

Steps to Reproduce:
1. Open Phoenix
2. Open lots of tabs
3. Press Windows 2000's close button on Phoenix window

Actual Results:  
Bang, all the tabs I had created are gone.  Oops, I only meant to close the
current one and clicked on the Windows Close button by force of habit.

Expected Results:  
'Are you sure you want to lose all the tabs in this window?'
I don't think Phoenix has forked anything related to tabs, so I think it will
inherit the fix from Mozilla once that is checked in.

Can some developer confirm this?
Andre,

We can always make this bug depend on bug 108973. When that gets "fixed", we'll
be able to determine if this does as well and take whatever action is warranted
at that point.
This is available via Tabbed Browsing Extesion (except it was broken recently).
 Piro is looking into it.
I've spoken with the developers and they are not going to implement this in Phoenix.
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → WONTFIX
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED
*** Bug 214371 has been marked as a duplicate of this bug. ***
*** Bug 216872 has been marked as a duplicate of this bug. ***
hi, i'm joining this discussion a bit late from a duplicate...

what's the reasoning behind the wontfix on this?  the seamonkey bug was fixed,
i'm not sure why the same bug in firebird shouldn't also be fixed.  i've lost
tabs this way more times than i care to remember, but i don't feel like
installing all of TBE just for a confirmation dialog.
I agree; this seems more like a basic feature than "bloat" that should be
offloaded into an extension. It's not something only a power user is going to
want, it directly contributes to making things easier for those new to tabbed
browsing.
*** Bug 218039 has been marked as a duplicate of this bug. ***
I also agree that this is a necessary feature rather than a bloat.  If you get
right down to it, tabs in general arn't really a "necessary" feature, but they
are included and this confirmation dialog should come with it as a package deal.

Also, i've been looking for Tabbed Browsing Extesion (mentioned in comment 3),
but it seems to be completely dead.  The only link I can find on the Mozilla
site (by search) is dead for both the XPI and the developer's page.
*** Bug 218565 has been marked as a duplicate of this bug. ***
This is a dataloss issue. And now that we've seen how useful this feature is in
Mozilla (now that bug 108973 is fixed), I request that this bug be REOPENED and
fixed. I see no good reason to not fix this important bug.

- No code bloat (a simple dialog)
- No UI bloat (never see it unless triggered, can turn off forever)
- Prevents dataloss
- Already cherished by many who use Mozilla

PS. After starting to like Firebird, this bug is putting major damper on my
impression that FB is headed in the right direction. (Perhaps the wontfix was
made before the dev's "saw the light".)
Keywords: dataloss
Summary: Warning when close window with multiple tabs → Show a Warning Dialog when Close a Window that has Multiple Tabs
on comment #4
can we users ask why? Thanks
*** Bug 221004 has been marked as a duplicate of this bug. ***
Also coming at this a bit late it seems, but am also mystified at the WONTFIX
call.  I too have been bitten by closing a window with several tabs open and
it's a major pain to have to find all the URLs and reopen them.  This is a
problem which is serious enough to stop me using Firebird as my main browser and
all becuause of the lack of a small patch which is already available in Mozilla
(bug #108973).

Make this an option if you like

Turn it off by default if you like (though I think it should be on)

..but please give us this option in the core program.
*** Bug 225855 has been marked as a duplicate of this bug. ***
I also agree.  Mistakes do occur, and some possibly vital window could be
accidently closed.  I think this feature is a necessity.
http://forums.mozillazine.org/viewtopic.php?t=45133

I am also mystified behind the WONTFIX placed on this bug. Despite the fact that
the dialog can be added to Firebird using the Tabwarning extension (which is
cross-platform), this feature seems far too useful to be left out. What was the
reasoning behind WONTFIXing this?
This is available as an extension.  
http://gorgias.de/mfe/
So that was the reason for the WONTFIX?
*** Bug 231015 has been marked as a duplicate of this bug. ***
Asa: Can this be reevaled? It's been a year almost since this was reviewed (back
when Firebird was Phoenix). Can this be looked into again. As commented on, this
is: 

- a dataloss issue
- should be simple to implement now that it's in Mozilla (so there's a
comparable codebase to look at, so not much work to implement likely)
- would not appear to be able to be labeled under the category of bloatware

This bug was decided upon well before the parallel Bug 108973 was even in the
process of getting addressed. This issue is also a key perception issue. Quoting
from a comment in the sister bug:

--
Just to help you make your mind: my girl friend is mainly a Mozilla user. When
she tried Konqueror 3.1 for the first time, she noticed the "do you really want
to close this window" message when you have mutliple tabs. Her reaction was a "I
want the same thing in Mozilla ! That's so useful to avoid losing all your work
!" reaction. The thing is that some people really use Mozilla to edit
_documents_. For example, my GF works in real estate and she uses Mozilla mainly
to edit properties' descriptions. For her, closing a tab by error is like
closing a document without saving it.
--

Please consider re-evaluating this dataloss issue.
OS: Windows 2000 → All
Hardware: PC → All
I too, think that this bug should be reopened.
This is an important dataloss issue and a simple one to address as it's got a
fix in Seamonkey.
Flags: blocking0.9?
A year onward, can we get some clarification on this? Is the relevant extension
going to be bundled with Firebird from 0.9 or 0.10 onwards? I can imagine the
Mozillazine forums being filled up with newbies who got annoyed by our handling
of tabbed browsing in this manner. I myself have committed similar mistakes when
learning to use graphical consoles from X in Linux, because I wasn't used to
having more than one prompt in one window.

I don't see why this is bloat or an obvious WONTFIX. A hidden option in
about:config could do the trick for users who want to wean themselves off this
option.
No need for a hidden pref IMO, all that's needed is a "dont show this again"
checkbox within the prompt.
PLEASE re-open this. The amount of times this feature saved me in Mozilla is
hard to count. I CANNOT understand the reasoning for not incorporating something
that is already fixed in the Mozilla suite??
Status: VERIFIED → UNCONFIRMED
Resolution: WONTFIX → ---
This dataloss issue should probably not be considered an enhancement.
Severity: enhancement → normal
A much needed requirement, especially when I am engrossed browsing and have ten
tabs active, then next thing they are all gine, just because I accidently hit
the wrong cross.
I think it's unnecessarily and annoying feature.
But this bloated function was introduced to firefox by Bug 68215.

*** This bug has been marked as a duplicate of 68215 ***
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Keywords: dataloss
Resolution: --- → DUPLICATE
(In reply to comment #31)
> I think it's unnecessarily and annoying feature.
> But this bloated function was introduced to firefox by Bug 68215.
> 
> *** This bug has been marked as a duplicate of 68215 ***

I've just read the entirety of bug 68215 and I don't see the connection between
these two bugs. What does an in-page DHTML event have to do with a warning
dialog to prevent closing multiple tabs at once?
> I think it's unnecessarily and annoying feature.

Well obviously some people think it's an essential dataloss preventing feature.
All it needs is a pref to disable it after the first time it's shown (i.e. on
the dialog/warning message itself).

Nobody here is suggesting that everyone must be forced to use it. While it could
be left to an extension, this is probably a very helpful feature to users
migrating from non-tab browsers, and leaving it out by default is wrong IMO.

I agree with the last comment, this is deinitely NOT a duplicate of the bug you
mentioned, which is a request to allow websites to prevent users closing a
window when they have made changes to a form.
Read comment #55 in bug 68215. They rolled up that fix along with the other.
Tested Firefix 20040220 build on XP and it looks good. This is a duplicate as it
did get fixed by the other bug's changes.
Status: RESOLVED → VERIFIED
Ah, there it is.

This is indeed now a duplicate. Someone needs to minus the blocking0.9? flag.
Flags: blocking0.9?
Can be added an extra button, that shows the option to close the tab selected.
Sometimes you click on the window close, instead of tabs close button.
You need to log in before you can comment on or make changes to this bug.