select box fails when adding customized headers in message filters

VERIFIED DUPLICATE of bug 212625

Status

Thunderbird
Mail Window Front End
--
minor
VERIFIED DUPLICATE of bug 212625
15 years ago
15 years ago

People

(Reporter: stolen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla Thunderbird 0.2 (20030901)

Found while editing message filters in Thunderbird 0.2.  When adding or editing
a message filter, you can customize the header which Thunderbird looks at. (for
example you can add X-List for some mailing lists and sort by that, instead of
using the subject).  After you are done with the customize box (either by
clicking okay or cancel) the only selection you are left with in the select box
is "subject" when normally there are quite a few selections.  When you close the
filter rules box and then click on new or edit again, it works normally, with
any added filters that were made in the previous step, and all is good.  Also,
if you leave the Filter Rules box in the background instead of closing it, it
will (after 20 or 30 seconds) also start working properly again.  If, instead of
closing it or putting it in the background, you leave it in the foreground,
after several minutes, it's still only giving you the "subject" selection.

Reproducible: Always

Steps to Reproduce:
1. click on tools -> message filters -> new
2. click on the "subject" select box and choose "customize..."
3. click cancel and click on the subject select box again

Actual Results:  
all selections other than "subject" have seemed to disapear

Expected Results:  
displayed all available selections

this bug occured with the default and "orbit grey" themes.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 212625 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.