If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

content: "€" displays € in the page instead of the euro sign (entity problem)

RESOLVED DUPLICATE of bug 204324

Status

()

Core
DOM: CSS Object Model
--
minor
RESOLVED DUPLICATE of bug 204324
14 years ago
14 years ago

People

(Reporter: Matthijs Groen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

If you have a style on, let's say: a table, and use the content attribute,

TD:before {
  content: "€";
}

the page renders in the cells the string "€" instead of the euro sign.
I guess this is a problem with all HTML entities. 

Reproducible: Always

Steps to Reproduce:
1. Make a table
2. 
TD:before {
  content: "€";
}

3. look at the cells.

Actual Results:  
€

Expected Results:  
euro sign

It is in all Gecko versions this way (netscape, Firebird, Mozilla)

Comment 1

14 years ago
That is correct behavior.  The entities are not supposed to be interpreted.  The
content value renders as straight text.

To get the effect you want, check the comments in bug 207461 and bug 204324.

*** This bug has been marked as a duplicate of 204324 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.