Data not being posted with HTML FORM POST in HTML Email Message

RESOLVED DUPLICATE of bug 242974

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 242974
15 years ago
14 years ago

People

(Reporter: Richard Bywater, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

If you use a HTML FORM tag with POST method in a HTML message read using
ThunderBird 0.2, the data does not get passed to the Action URL.  GET method
works fine.

Reproducible: Always

Steps to Reproduce:
1. Send a HTML email containing something similar to the following:
<form action="http://myhost/testing" method="post"><input
 name="Blah" type="text"><input value="test submit" type="submit"></form>
2. Open the email in ThunderBird
3. Type something in the text box and submit

Actual Results:  
When ThunderBird opens the Browser, the browser actually does a GET not a POST
hence all POST values are lost.

Expected Results:  
POSTed data - unless of course there is no way of doing this when initiating the
browser connection from ThunderBird.

Note that Mozilla Mail seems to work fine - it just seems to be ThunderBird.

Updated

15 years ago
QA Contact: asa

Comment 1

15 years ago
I doubt it is possible to transfer POST data to an external browser but maybe
someone with more technical knowledge can give a definite answer?

Comment 2

14 years ago
I have been having the same problem. 

This comes up for me when I try to reply to a comment on LiveJournal. Comments
are sent to me ("Reply to your comment" or "Reply to your post") with an option
to send a further reply. The form (method="post") includes a text area and a
"Post Reply" button.

In Mozilla Mail, clicking the button opens a browser window and posts the
message. In Thunderbird, it opens the browser, but LiveJournal gives this
response: " Comment not posted: POST required, or missing parameter."

Comment 3

14 years ago
duping to newer bug because discussion has been started in the newer bug, with
my apologies for not spotting it earlier.

*** This bug has been marked as a duplicate of 242974 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.