Mac-only: Tasks > Tools > Java Console does nothing

VERIFIED FIXED

Status

defect
P3
normal
VERIFIED FIXED
20 years ago
9 years ago

People

(Reporter: bugzilla, Assigned: nezbo)

Tracking

Trunk
PowerPC
Mac System 8.6
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
summary sez it all: going to the Tasks > Tools > Java Console doesn't bring up
the java console (nothing happens). tested with today's bits: 1999121609 (mac
and win) and 1999121608 (linux).

if this isn't implemented, could it be greyed-out in the menu? (so as to avoid
potentially confusing users.) thx!

Comment 1

20 years ago
Transferred to the OJI category

Updated

20 years ago
Assignee: malini → drapeau
Component: Java FrontEnd → OJI

Comment 2

20 years ago
Changing to OJI category

Comment 3

20 years ago
NOTE: just changed primary QA contact person.(everything else remains the same)
QA Contact: leila.garin → rpallath

Comment 4

20 years ago
There will probably not be time to fix this one for Beta1, but after the JVM
is working again with Beta1 on all platforms (except Linux; no OJI-compliant
JVM is yet available), we'll get to implementing this.
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 5

20 years ago
*** Bug 22644 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Blocks: 27407

Comment 6

20 years ago
For the record, this used to work, but something else changed and now it 
doesn't.  Sound familiar?
Assignee: drapeau → edburns
Status: ASSIGNED → NEW

Comment 7

19 years ago
I tried the 2000022108 build on WinNT and it works just fine for me. We can assume that anyone who tried  _made_sure_  that 
Java was installed with their particular build (for those using opt bits and an installer) ...right?

Comment 8

19 years ago
So for Mac and Linux can we put a . in front of the menu items or gray it out 
until the functionality is present.   I think some on the browser team will have 
to that, mcafee for Linux and Matt ?? for Mac.

Comment 9

19 years ago
OJI (or presence of JVM) should enable/disable this menu item,
we shouldn't have to do platform-specific UI hacks here.

Comment 10

19 years ago
I haven't witnessed this bug yet so hold off doing anything.  I agree with Chris
though, it should be done dynamically.

Comment 11

19 years ago
After following the below steps, I have determined that I can't reproduce this 
bug.  If you follow the below steps and determine the same, then please reopen.

02 March 00

Here are the steps I took to enable the viewing of applets in mozilla.

STEP 8 IS THE MOST IMPORTANT, and UNUSUAL step.

1. Check tinderbox to see that it's green for win32 clobber

2. Checkout SeaMonkey at around 11:30am on 02 March 2000

3. Built Mozilla with MOZ_DEBUG=1

4. Used the WINNT Add/Remove programs feature to remove any JRE and JDK
   instance I had installed on my machine.  Then I rebooted.

5. Used a find command to make sure there were no instances of any of
   the following files on my C: drive:

   jpins32.dll
   npjava*.dll
   jpishare.dll
   jaws.jar

   This step is also intended to catch the case where you have Netscape
   Navigator 4.x with the Java plugin installed, which I don't.  If you
   do, you must make sure that you don't have the plugin installed.

6. Downloaded the JRE Release Candidate (RC) 1 release by visiting:

   http://developer.java.sun.com/developer/earlyAccess/j2sdk13/
  
   And choosing the "One large bundle" option under the heading

     Internationalized version of Java 2 Runtime Environment 

7. Ran the installer exe.

8. Unzipped George's zip file on top of the install location, which for
   me was C:\Program Files\JavaSoft\JRE\1.3 .

9. Copied C:\Program Files\JavaSoft\JRE\1.3\bin\npjava*.* to my mozilla
   plugins directory, which is:

   D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\plugins

10. Ran 

   D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\mozilla.exe

After doing the profile manager dance, I was able to view applets
without java-related crashes.

Comment 12

19 years ago
After following the below steps, I have determined that I can't reproduce this 
bug.  If you follow the below steps and determine the same, then please reopen.

02 March 00

Here are the steps I took to enable the viewing of applets in mozilla.

STEP 8 IS THE MOST IMPORTANT, and UNUSUAL step.

1. Check tinderbox to see that it's green for win32 clobber

2. Checkout SeaMonkey at around 11:30am on 02 March 2000

3. Built Mozilla with MOZ_DEBUG=1

4. Used the WINNT Add/Remove programs feature to remove any JRE and JDK
   instance I had installed on my machine.  Then I rebooted.

5. Used a find command to make sure there were no instances of any of
   the following files on my C: drive:

   jpins32.dll
   npjava*.dll
   jpishare.dll
   jaws.jar

   This step is also intended to catch the case where you have Netscape
   Navigator 4.x with the Java plugin installed, which I don't.  If you
   do, you must make sure that you don't have the plugin installed.

6. Downloaded the JRE Release Candidate (RC) 1 release by visiting:

   http://developer.java.sun.com/developer/earlyAccess/j2sdk13/
  
   And choosing the "One large bundle" option under the heading

     Internationalized version of Java 2 Runtime Environment 

7. Ran the installer exe.

8. Unzipped George's zip file on top of the install location, which for
   me was C:\Program Files\JavaSoft\JRE\1.3 .

9. Copied C:\Program Files\JavaSoft\JRE\1.3\bin\npjava*.* to my mozilla
   plugins directory, which is:

   D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\plugins

10. Ran 

   D:\Projects\mozilla\dist\WIN32_D.OBJ\bin\mozilla.exe

After doing the profile manager dance, I was able to view applets
without java-related crashes.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 13

19 years ago
This is working for windows but not for Mac in the 2000021317.  I'm going to reopen this bug.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 14

19 years ago
*** Bug 8010 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Depends on: 31670

Comment 15

19 years ago
Sounds like this is a sad mac-only bug now.  :-(
It would be nice to have this fixed... but it is not destabilizing M15 (which is 
frozen now).  I'm pushing this bug to M16 to facilitate the M15 branching.
Target Milestone: M15 → M16

Comment 16

19 years ago
Mac bug.
Assignee: edburns → loki-sun
Status: REOPENED → NEW

Comment 17

19 years ago
changing os to mac.
OS: All → Mac System 8.6

Comment 18

19 years ago
this is a dup of 31670 (or if anything 31670 depends on this, not the other way 
around as listed)... my kingdom for a dup status indicator..ugh

Comment 19

19 years ago
changing 31670 to this blocking it.. changing platform to mac..  jvmmgr in oji 
never has getConsole invoked from the menu cell action; so something is not 
hooked up between those two.

ugh - another wunderbar design of bugzilla: since someone already put this as 
depending on 31670 (instead of the opposite which is correct), i can't take the 
dependency out and put it in the block in one step... lovely... i'll try it in 
two steps..
No longer depends on: 31670
Hardware: All → Macintosh

Comment 20

19 years ago
step two.. adding it back in as being blocked.
Blocks: 31670

Comment 21

19 years ago
(more notes for future workers) specifically, the nsJVMManager::ShowJavaConsole  
method never gets messaged on the mac platform.

Comment 22

19 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.

Comment 23

19 years ago
No target milestone: no resources to work on Macintosh bugs right now.
Target Milestone: M16 → ---

Comment 24

19 years ago
summary
Summary: Menu: Tasks > Tools > Java Console does nothing → Mac-only: Tasks > Tools > Java Console does nothing

Comment 25

19 years ago
Re-assigning this bug to myself, as Loki no longer works at Sun.  Leaving target
milestone as undefined, as there are no resources to work on Macintosh problems.
Assignee: loki-sun → drapeau

Comment 26

19 years ago
Re-assigning to Terry Noyes.  Does the Java Console work now?  I dunno.
Assignee: drapeau → tnoyes
(Reporter)

Comment 27

19 years ago
nope --trying the bring up the java console on mac now crashes mozilla. filed
bug 68207 for that.
(Assignee)

Comment 28

18 years ago
please see bug #6872, as those proposed fixes appear to also cure the Java
Console bugs.
(Reporter)

Comment 29

18 years ago
not sure if this is truly dependent, but adding dep on bug 6872 if terry is
right.
Depends on: 6872
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 30

18 years ago
Hi Terry, what's the status on this?

Comment 31

18 years ago
Status?
(Assignee)

Comment 32

18 years ago
Waiting for bug #6872.  With those fixes the console comes up and can be used
for output, but only then will we be able to see if there are actual Java
Console bugs.
(Assignee)

Comment 33

18 years ago
The fix for bug #6872 landed yesterday, and I've tested successfully with a
yesterday build and a today build. Changing to FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Comment 34

18 years ago
Verified with the Netscape 6 2001041908 build.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.