100% CPU Utilization when checking multiple IMAP accounts

RESOLVED DUPLICATE of bug 224381

Status

Thunderbird
Account Manager
--
critical
RESOLVED DUPLICATE of bug 224381
15 years ago
14 years ago

People

(Reporter: William Anderle, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030923 Firebird/0.7+ (aebrahim)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030923 Firebird/0.7+ (aebrahim)

When you setup several IMAP accounts, when Thunderbird check mail the CPU
utilization is driven UP to 100% (And I have an Athlon XP 2300Mhz). While I'm
playing some games, I noticed that when Thunderbird checks automatically email
(each 10minutes) the game slows down terribly. I'm not the only one having this
problem, I report here some links to mozillazine:
http://forums.mozillazine.org/viewtopic.php?t=25707
http://forums.mozillazine.org/viewtopic.php?t=25044&highlight=imap+cpu
http://forums.mozillazine.org/viewtopic.php?t=25545&highlight=imap+cpu

I'm reporting that for Thunderbird 0.3a 2003/09/17 build.

Reproducible: Always

Steps to Reproduce:
1. Set up 3 IMAP account
2. Open Task Manager
3. Check IMAP mail and look at the CPU utilization

Actual Results:  
CPU utilization up to 100%, system slowed down, if you're playing you'll notice
a great frame drop.

Expected Results:  
CPU utilization much much lower

Comment 1

15 years ago
I can confirm this is still a problem in Mozilla Thunderbird 0.3 (20030924). It
has plagued me for weeks,, and it would be great if someone could get it pinned
down.

Comment 2

15 years ago
This awful bug still exists in thunderbird 0.3 RC3!!!

Updated

15 years ago
Flags: blocking0.4?

Comment 3

15 years ago
I thought for a while that this was fixed in the "Mozilla Thunderbird 0.3
(20031008)" build because it took some time for it to occur, but this bug is
still alive and well. Drat!

Comment 4

15 years ago
I don't know about checking IMAP accounts (although I do have some configured),
but I get 100% CPU when I fail authentication on a news server.

I am using the release version of Thunderbird 0.3.

Comment 5

15 years ago
It looks no one cares about this bug. 
It renders Mozilla Thunderbird unusable in multitasking environment. 
I've checked the newest nightly builds - the problem still exists.
(Assignee)

Comment 6

15 years ago
I think this is a dupe. Will be in the next (not the 11/19) round of builds.

*** This bug has been marked as a duplicate of 224381 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Flags: blocking0.4?
You need to log in before you can comment on or make changes to this bug.