Floated div after page break missing from Print or Print Preview

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Jeffrey Knauth, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

682 bytes, text/html
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

When a Print or Print Preview is done for the page in the attached test
case, the DIV id="foot" section is not printed or previewed.  However,
that section renders correctly in the normal display.

This bug was originally reported as part of
http://bugzilla.mozilla.org/show_bug.cgi?id=216195
and is being reported separately here because it is likely a different
problem.   

Reproducible: Always

Steps to Reproduce:
1. Do a Print or Print Preview of the file in the attached test case.
2.
3.

Actual Results:  
The DIV id="foot" section is missing.

Expected Results:  
The output should have ended with:

          footer ####################################  footer
          footer ####################################  footer
          footer #######  This text does not ########  footer
          footer #######  get printed and is ########  footer
          footer #######  not displayed in   ########  footer
          footer #######  Print Preview.     ########  footer
          footer ####################################  footer
          footer ####################################  footer
(Reporter)

Comment 1

15 years ago
Created attachment 131998 [details]
Test case

Test case for missing DIV section in Print and Print Preview.

Comment 2

14 years ago
Reproduced on Mozilla 1.7b (2004031616)
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316

Lines are missing between pages 2-3, 3-4, and 4-5.  Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
see attachment 158940 [details] for a slightly updated testcase (more CSS removed)
Keywords: testcase

Comment 4

13 years ago
(In reply to comment #2)
> Reproduced on Mozilla 1.7b (2004031616)
> Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316
> 
> Lines are missing between pages 2-3, 3-4, and 4-5.  Confirming.

I ordered some tix today from www.klm.com and had missing output as well. One
funny thing i noted that when opening the page to be printed in the Print
Preview window, i was actually able to scroll in the preview!!

It showed me the full A4 page, with a large white space, but moving my mouse
wheel, actually made new text come up, within the very same A4 that was beind
displayed. 

I'm not sure if it's related, but worth mentioning all the same.
I'm elevating the severity to CRITICAL based on the resulting "loss of data"
when a page is printed, but data is missing.
Severity: normal → critical

Comment 5

13 years ago
*** Bug 276459 has been marked as a duplicate of this bug. ***

Comment 6

11 years ago
This bug still repros on Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070613 Minefield/3.0a6pre.   

The footer is missing in print and print preview.
This is now works for me with Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a9pre) Gecko/2007092605 Minefield/3.0a9pre ID:2007092605 and on Fedora FC7

Closing as Works for me
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME

Comment 8

7 years ago
This bug actually still occurs. Reopening. Tested with Firefox 3.6.13 on Linux x64, Ubuntu 10.10 (using their version of Firefox). Note that comments 2 and 4 are describing separate issues.

I think the confusion comes from the fact that the testcase here came from another bug (bug 216195) that had 3 separate issues in it. Those 2 other issues are now WFM, but the issue here (the missing footer DIV) still occurs. I'll attach another testcase shortly.
Severity: critical → normal
Status: RESOLVED → REOPENED
OS: Windows XP → All
Hardware: x86 → All
Resolution: WORKSFORME → ---

Comment 9

7 years ago
Created attachment 510108 [details]
minimized testcase

This is a greatly reduced testcase that shows only the one issue for this bug.

The floated footer DIV on the bottom does not appear in print preview. It is key that the spacer DIV on top of it is also floated and large enough to force the footer DIV onto the second page. Note that this means if for some reason you see the footer DIV on the first page, *you have to increase the size of the spacer DIV*.
Attachment #131998 - Attachment is obsolete: true

Comment 10

7 years ago
Changed summary to better describe the problem.
I did some searching for similar bugs, and bug 522604 seems related, though I cannot say if it is the same problem or not.
Blocks: 521204
Status: REOPENED → NEW
Summary: Displayed page vs. Print and Print Preview: Missing DIV section lines → Floated div after page break missing from Print or Print Preview
James, note that Carsten was testing with an alpha of Firefox 4 when he said that things work for him, whereas you're testing with Firefox 3.6.  And there was no confusion; float printing was substantially reworked in Gecko 2.0, and this bug is no longer present on trunk.
Status: NEW → RESOLVED
Last Resolved: 10 years ago7 years ago
Resolution: --- → WORKSFORME
Assignee: printing → nobody
QA Contact: printing

Comment 12

7 years ago
Really? Carsten's comment was from back in 2007, and with an alpha of Firefox 3, not 4. Although if you just tested this bug yourself with the trunk, I suppose it doesn't matter. Could you please check if bug 522604 is also WFM now?
You need to log in before you can comment on or make changes to this bug.