floated fieldset containing table losing table structure

RESOLVED DUPLICATE of bug 129346

Status

()

Core
Layout: Floats
RESOLVED DUPLICATE of bug 129346
14 years ago
14 years ago

People

(Reporter: Hixie (not reading bugmail), Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [reflow-refactor], URL)

(Reporter)

Description

14 years ago
If you have a table inside a fieldset and float your fieldset, the table falls
apart. See the testcase in the URL field.
This happens because the fieldset does not do a second reflow (with constrained
width) after doing an unconstrained with reflow on its kids....
Summary: floated fieldset containing table losing table structure → [reflow-refactor]floated fieldset containing table losing table structure
Summary: [reflow-refactor]floated fieldset containing table losing table structure → floated fieldset containing table losing table structure
Whiteboard: [reflow-refactor]

Comment 2

14 years ago
fieldset probably need something similiar to the patch in bug 26650

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 129346 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.