Can't build with Binutils Candidate

VERIFIED FIXED

Status

defect
--
major
VERIFIED FIXED
16 years ago
7 months ago

People

(Reporter: nilson, Assigned: bryner)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030917 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030917 Firebird/0.6.1+

When I try to build with the new required version of Binutils, my builds always
fail right toward the end of the process.  I'm using the exact same build
environment that build many previous Firebirds using the older binutils.  I
applied CLS's patch to allow building with Win32API 2.4 to my tree before it was
checked in, and I was building with Win32 API 2.4/ and the current binutils.

The required binutils is a candidate release, BTW.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Assignee

Comment 1

16 years ago
Can you attach a log of the build failure?

Comment 2

16 years ago
I'm not 100% sure but I believe this is the same problem I have been running
into since upgrading to the candidate release of binutils (binutils-2.14.90) for
MinGW.  My build gets pretty far, and then consistently breaks at this point:

Creating Resource file: module.res
/cygdrive/c/mozilla/mozilla/build/cygwin-wrapper windres -O coff --use-temp-file
 -DMOZ_PHOENIX --include-dir /cygdrive/c/mozilla/mozilla/browser/app -DOSTYPE=\"
WINNT5.1\" -DOSARCH=\"WINNT\" --include-dir ../../dist/include/appshell --includ
e-dir ../../dist/include/string --include-dir ../../dist/include/xpcom --include
-dir ../../dist/include/xulapp --include-dir ../../dist/include --include-dir ..
/../dist/include --include-dir ../../dist/include/nspr -o module.res /cygdrive/c
/mozilla/mozilla/browser/app/module.rc
c:\mozilla\mingw\bin\windres.exe: c:/mozilla/mozilla/browser/app/module.rc:106:
syntax error
make[4]: *** [module.res] Error 1
make[4]: Leaving directory `/cygdrive/c/mozilla/mozilla/browser/app'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/cygdrive/c/mozilla/mozilla/browser'
make[2]: *** [libs] Error 2
make[2]: Leaving directory `/cygdrive/c/mozilla/mozilla'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/cygdrive/c/mozilla/mozilla'
make: *** [alldep] Error 2
Assignee

Comment 3

16 years ago
Chris, any ideas on this? Bernie, can you attach the generated module.rc file
from mozilla/browser/app?

Comment 4

16 years ago
Posted patch a fixSplinter Review
i think this should fix it.  it will also let firebird build with gcc 3.3.1
Assignee

Comment 5

16 years ago
I checked in the patch; Bernie, can you confirm that this fixes the build for you?
Reporter

Comment 6

16 years ago
I'm trying it right now...

Comment 7

16 years ago
Comment on attachment 132436 [details] [diff] [review]
a fix

Same as the fixes from bug 203292. r=cls
Attachment #132436 - Flags: review+
Reporter

Comment 8

16 years ago
Shouldn't the bug be confirmed?

Comment 9

16 years ago
I forgot to attach my email address when I initially commented on the bug, so
I've been out of the loop.  Sorry about that.  If need be I can test the
checked-in patch tomorrow afternoon and post my findings here.

My guess based on looking at the patch, though, is that it should fix the
problem.  When I looked at module.rc after the build error showed up, I saw this
part of the code around line 106:

#ifndef __MINGW32__
   IDB_SPLASH,
#endif
   IDB_SPLASH,

Comment 10

16 years ago
Well, I've built off of MinGW and Cygwin, with the latest versions (candidate
releases) just now, and it's working just fine.  I didn't attempt building
earlier before the check-in, though, since I just re-configured and updated
MinGW with the binutils and such, because I haven't tried a build in about a month.
Assignee

Comment 11

16 years ago
marking fixed based on comments
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Reporter

Comment 12

16 years ago
Got a successful build.  Well done, guys :)

Comment 13

16 years ago
the same problem exist on Thunderbird.

basiclly it's the same fix just in another file:
mail/app/module.rc like 114
verified fixed 2003-11-09
Status: RESOLVED → VERIFIED
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.