Closed Bug 220998 Opened 20 years ago Closed 19 years ago

Allowing to have blocked/dependson/keyword info in bug entry templates

Categories

(Bugzilla :: User Interface, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: ludovic, Assigned: myk)

References

Details

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030925

This patch allows to have values for blocked/keywords/dependson info in bug
entry template.. This is very usefull for another patch which allows to add a
quick button to add a dependency in the same product/group of a bug..


Reproducible: Always

Steps to Reproduce:
This is the patch for 2.17 Head. However it should work in most versions that
use templates
Attachment #132510 - Flags: review?
Comment on attachment 132510 [details] [diff] [review]
Dependencies and Keywords in bug entry template

>--- web.ref/enter_bug.cgi	2003-09-29 09:52:35.425219000 
>       <td>
>-        <input name="dependson" accesskey="d">
>+        <input name="dependson" accesskey="d" value="[% dependson %]">
>       </td>
>     </tr>
>     <tr>
>@@ -263,7 +263,7 @@
>         <strong>Blocks:</strong>
>       </td>
>       <td>
>-        <input name="blocked" accesskey="b">
>+        <input name="blocked" accesskey="b" value="[% blocked %]">
>       </td>
>     </tr>
>   [% END %]

You missed FILTER html in two places there.
Attachment #132510 - Flags: review? → review-
Attachment #132510 - Attachment is obsolete: true
Attachment #139862 - Flags: review?(kiko)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Bugzilla 2.18
Whiteboard: [applied to b.m.o]
Comment on attachment 139862 [details] [diff] [review]
patch v2: FILTERs values

Look correct. I guess this will be mainly useful for buglinks which set these
parameters in specific instances..
Attachment #139862 - Flags: review?(kiko) → review+
Checking in enter_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/enter_bug.cgi,v  <--  enter_bug.cgi
new revision: 1.87; previous revision: 1.86
done
Checking in template/en/default/bug/create/create.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/create/create.html.tmpl,v
 <--  create.html.tmpl
new revision: 1.25; previous revision: 1.24
done
Status: NEW → RESOLVED
Closed: 19 years ago
Flags: approval+
Resolution: --- → FIXED
Whiteboard: [applied to b.m.o]
*** Bug 217027 has been marked as a duplicate of this bug. ***
*** Bug 181486 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.