[Linux] Clipboard only available while Thunderbird is open

RESOLVED DUPLICATE of bug 311340

Status

--
major
RESOLVED DUPLICATE of bug 311340
15 years ago
11 years ago

People

(Reporter: shwag, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030923 Epiphany/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030923 Epiphany/1.0

Clipboard only availabe while Thunderbird is open.  Once you close thunderbird
and then go over to another app, you can't paste the string that you thought you
had just copied.  If you leave thunderbird open, you can still paste into other
apps.  

Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago
I believe this is due to MF not supporting anything relating to the OS in
Linux--be it http: links or the clipboard.  Is there a bug for OS integration?

Comment 2

14 years ago
WFM with Windows.  Still a problem under Linux?
Summary: Clipboard only availabe while Thunderbird is open → [Linux] Clipboard only available while Thunderbird is open

Comment 3

13 years ago
That's an issue with X.  X does not maintain a central clipboard.  It expects clients to "take ownership" of the clipboard and then stick around to respond to requests for the clipboard data.

By leaving Thunderbird open, you're keeping it available to respond to clipboard requests.  When you close Thunderbird, it is no longer able to respond to those requests.

Windows has a central clipboard and is able to maintain that clipboard in the face of clients exiting.

I believe that there are X tools that act as clipboard daemons to simulate the Windows behavior.
QA Contact: front-end

Comment 4

11 years ago
This seems to be related to recent changes in freedesktop clipboard manager specification which you can find here :

http://www.freedesktop.org/wiki/ClipboardManager

This bug affects a lot of programs, but some programs like gedit, inkscape, pidgin are already fixed to comply with the specification.
Assignee: mscott → nobody
Hardware: PC → All
This is a toolkit issue; duping to the relevant toolkit bug.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311340
You need to log in before you can comment on or make changes to this bug.