Shockwave plugin does not work on Mac (app needs vers resource)

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: vintz.nicolas, Assigned: peterv)

Tracking

({fixed-aviary1.0})

unspecified
PowerPC
macOS
fixed-aviary1.0
Points:
---
Bug Flags:
blocking0.9 -
blocking-aviary1.0mac +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030926 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20030926 Firebird/0.7

Trying to access a page containing a shockwave object, the plugin won't show (it
is like there is no plugin installed).

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.cinemaware.com/browser/dotc/final.asp
2. A window open on Macromedia site to download a plugin
3. 

Actual Results:  
No display from the plugin

Expected Results:  
The content of the shockwave object should be shown

It works with Mozilla 1.5 RC2

Comment 1

16 years ago
Confirming. Surprised this hasn't been reported yet (as far as I can tell).
Using Shockwave 9 plug-in, works fine under Camino as well. 
Also of note is that the Macromedia download site doesn't recognize Firebird (or
Camino) as legitimate browsers and so it's impossible to use them to download
the plugin, but that's a problem on Macromedia's side.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
Are you certain it's a problem with Macromedia's site? I was under the
impression that they didn't have Shockwave plugin that supports Firebird/Firefox
yet. This would explain why not only their site says they don't have a suitable
plugin (even though they initially tease us with the Shockwave 9 link), but also
why it fails to work. 

I've asked them about this several times in the past, but they never respond.

Either way, wouldn't this be a bug with their plugin and not the browser?

Comment 3

15 years ago
I thought the plugin is installed system wide.  Camino handles it fine.

Comment 4

15 years ago
I found the public beta of Shockwave player 10 on Macromedia site.

http://www.macromedia.com/software/shockwaveplayer/beta/

I installed this beta version of shockwave player and I tested on the following
page.

http://sdc.shockwave.com/shockwave/welcome/

Shockwave player didn't work in Firefox0.8.  It works in Mozilla and Camino.
See the following topics of Firefox Bugs forum for details.

http://forums.mozillazine.org/viewtopic.php?t=40370

Comment 5

15 years ago
(In reply to comment #0)
> 1. Go to http://www.cinemaware.com/browser/dotc/final.asp

Something strange happens in this page..... Not only Firefox 0.8 final crashes,
but IE6 with all patches crashes too!!!! I think further investigation is
needed, I tried differents Shockwave pages (e.g
http://www.bu.edu/com/html/shockdemos.html or http://www.lumen8design.com/horse/
and all of them works w/o problems), and all of this happens using Win XP, so
I'm not sure this is MacOS X only, or at least this page is not a good example :-)

> It works with Mozilla 1.5 RC2

It works with Mozilla 1.6 final too on Win XP (but not with IE6!!!!)
(Reporter)

Comment 6

15 years ago
Here is another link that does not work under Mac OS X :
http://farfar.2038.com/cow2/english/loader.html
(Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; fr; rv:1.6) Gecko/20040206
Firefox/0.8)

Works with Safari.

Comment 7

15 years ago
This isn't an instant remedy, but I finally received a response from Macromedia
about the problem:

"Firebird is actually not an officially supported browser for Shockwave Player.
The best thing to do would be to fill out the Feature Request form here:
http://www.macromedia.com/support/email/wishform/
and have other Firebird users do the same. 
The engineers view the wishlist regularly and would consider porting the player
to Firebird if enough users request for it."

So, could anyone with a spare minute please take the time to log a request on
their site? Maybe they'll take notice of us :)

Comment 8

15 years ago
The reason Shockwave does not work is that it needs to be able to find a 'vers'
resource in the application. See bug 151677.

This should be an easy fix.
Summary: Shockwave plugin does not work → Shockwave plugin does not work (app needs vers resource)

Comment 9

15 years ago
Firefox also needs to pick up the 'aete' resource so that AppleScripting works.
It basically needs the packaging steps here:
http://lxr.mozilla.org/seamonkey/source/xpfe/bootstrap/appleevents/Makefile.in#87

and here:
http://lxr.mozilla.org/seamonkey/source/xpfe/bootstrap/Makefile.in#442

though I can't immediately see where the 'vers' resource comes from.
Assignee: firefox → bugs

Comment 10

15 years ago
This sounds like such a simple packaging change, it'd be a shame if it didn't
make it in before the next milestone release (which I assume isn't far off?). A
lot of people use Shockwave and it'll be a glaring problem if it doesn't work.

Is there anyone working on this? Or anyone who is responsible for packaging that
should be notified? :)

Updated

15 years ago
Flags: blocking0.9?
not a 0.9 blocker, should be done for mac 1.0
Flags: blocking0.9? → blocking0.9-

Comment 12

15 years ago
That's a shame. This one's pretty serious. If it was a Windows problem, lots of
people would be squealing. Setting request for 1.0, anyway.
Flags: blocking1.0?

Comment 13

15 years ago
Actually, should the component be set to 'build-config' and the assignee set
accordingly and/or the people who are responsible for creating the Mac builds
notified?

Wasn't sure, and for all I know Ben might be the person who does that anyway.
+ing... can someone knock together a patch based on smfr's suggestion?
Flags: blocking1.0? → blocking1.0+
Flags: blocking1.0+ → blocking1.0mac+
*** Bug 243220 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
Severity "normal"?  How about major?

Just, fyi, as a normal human, I don't consider a broken shockwave plugin issue
to be Normal.  In fact, it's a usability deal breaker for me.

Well, quick searches might keep me around a while longer, but of the seven
browsers I have installed, Firefox 0.9 is the only one that can't find the
shockwave plugin sittin' pretty in the correct library folder?  That's not
exactly inspiring, you know.

Comment 17

15 years ago
Well, it's annoying, but it's not causing any core web functionality to fail,
just a plug-in. Granted, it's a pretty damn important plug-in, but still....

I don't think changing the severity is going to affect the rate at which this
bug is fixed, though. The coders are aware of how important it is. The fix
sounds like it's a fairly simple one, though, and if I had any clue about
browser coding, I'd submit a patch myself ;) Simon Fraser already patched Camino
for the same issue, and presumably the fix for this one would be almost the same?

Comment 18

15 years ago
*** Bug 251971 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
I don't want to open a new bug report on Linux, but Firefox on Linux is failing
as well with this plugin.  Whatever change was made was recent, this same plugin
worked fine in the daily builds up to about 2-3 weeks ago.  Now we get this:

LoadPlugin: failed to initialize shared library
/u/firefox_cvs_20040816/firefox/plugins/libflashplayer.so
[/u/firefox_cvs_20040816/firefox/plugins/libflashplayer.so: invalid ELF header]
*** loading the extensions datasource

I also would agree that this is "critical".  Unfortunately some pages that we
use (such as www.dmdata.com) are 100% Shockwave and have no HTML fallback code.
 Let me know if you want this opened as a new bug report.  Perhaps OS should be
changed to "All"?

Comment 20

15 years ago
Please open a new bug report. You're describing a different issue.
Summary: Shockwave plugin does not work (app needs vers resource) → Shockwave plugin does not work on Mac (app needs vers resource)

Comment 21

15 years ago
(In reply to comment #19)
> I also would agree that this is "critical".  Unfortunately some pages that we
> use (such as www.dmdata.com) are 100% Shockwave and have no HTML fallback code.
>  Let me know if you want this opened as a new bug report.  Perhaps OS should be
> changed to "All"?


I could load this website in OS X just fine.

My build is: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3
My OS is:  Mac OS X 10.3.5

Comment 22

15 years ago
Loads for me in Mac OS X, too, so definitely unrelated to this bug. Despite the
word "shockwave" being used several times in the page source, I have a suspicion
that it's just Flash.

Comment 23

15 years ago
Moving this to another bug report, thanks for feedback.

Comment 24

15 years ago
With respect to the Mac OS X bug, there's a kind of work-around that will allow
the Shockwave plugin to work, until this is fixed properly. As much as I've
tested it, it works fine for me, but I warn you that I'm no expert, so if it
crashes your system, I told you so ;)

If you have Mozilla installed, open up the bundle (ctrl-click on the application
and select "Show Package Contents"). Go to Contents/Resources/ and take a copy
of the file "mozilla-bin.rsrc"
Open up your Firefox bundle and move the copied file into the Resources folder.
Rename it to "firefox-bin.rsrc". Start Firefox and Shockwave should work.

I'm guessing the proper fix would just involve including an adapted copy of that
file when Firefox is built. I don't have a tool that allows me to open that
.rsrc file in Jaguar, so I don't know how much of it is necessary, or what
should be changed to adapt it.

Comment 25

15 years ago
Using QuickConvert and then ResEdit, I pried open the mozilla-bin.rsrc file
tonight and found that it just contained an aete resource.

However I discovered that if I removed the aete resource, effectively leaving a
blank resource file, converted it back, and placed that in the Resources
directory, the Shockwave plugin still loaded.

The plugin seems to require a resource file (sticking a fake one made with Word
doesn't work), but it doesn't seem to require anything in it.

Any thoughts on this, Simon? Should we include an aete resource anyway?
Peterv, any chance you could have a look at this bug? Maybe we need some "vers"
resource love in our new build system, or something?

Comment 27

15 years ago
Are you sure we need a 'vers' resource?

As I mentioned in comment 24 and comment 25, adding an empty firefox-bin.rsrc is
enough to allow the plugin to work. Also, the plugin loads in Mozilla, but I
haven't seen a 'vers' resource bundled with that browser (although maybe I
simply missed it). Removing the mozilla-bin.rsrc file from the Mozilla bundle
prevents the plugin from loading in that browser.

Finally, the Apple tech notes suggest that 'vers' resources aren't used in OS X
apps. From http://developer.apple.com/technotes/tn/tn2013.html :

"A 'plst' resource provides the information that previously resided in the
'vers', 'open', 'FREF', 'BNDL', and 'kind' resources of pre-Mac OS X systems. In
fact, on Mac OS X, the information in a 'plst' resource supersedes the
information in the old-style resources."

I actually emailed Macromedia tech support and asked them for some insight on my
findings, but strangely they never replied ;)
(Assignee)

Comment 28

15 years ago
Posted patch v1Splinter Review
This fixes it for me.
(Assignee)

Updated

15 years ago
Assignee: bugs → peterv
Status: NEW → ASSIGNED
(Assignee)

Updated

15 years ago
Attachment #157802 - Flags: superreview?(bryner)
Attachment #157802 - Flags: review?(bryner)

Comment 29

15 years ago
I agree this bug should be 'critical' or at least 'major' lack of shockwave
significantly effects usability.

comment #24 works for me, this seems like an easy fix.

It's not clear to me what #28 means, what should one do with this attachment.
Flags: blocking-aviary1.0PR?
*** Bug 257797 has been marked as a duplicate of this bug. ***
Comment on attachment 157802 [details] [diff] [review]
v1

r+sr=bryner and me
Attachment #157802 - Flags: superreview?(bryner)
Attachment #157802 - Flags: superreview+
Attachment #157802 - Flags: review?(bryner)
Attachment #157802 - Flags: review+
(Assignee)

Comment 32

15 years ago
Comment on attachment 157802 [details] [diff] [review]
v1

Checked in on trunk, asking for aviary approval.
Attachment #157802 - Flags: approval-aviary?
Comment on attachment 157802 [details] [diff] [review]
v1

a=asa for branch checkin.
Attachment #157802 - Flags: approval-aviary? → approval-aviary+

Comment 34

15 years ago
Confirmed fixed on trunk 20040905. Thanks Peter!! :)

I'm not sure if anything within the 'aete' resource in the .rsrc file should be
changed for Firefox. I admit I don't know how to interpret it anyway... it looks
like a bunch of gibberish to me. I did notice the Seamonkey bundle signature
("MOZZ") in there, however, rather than the Firefox one ("MOZB"). I don't know
if that's important, or if anything's going to use the 'aete' resource anyway.
Firefox has survived this long without needing one, so it's probably not
important, but thought I'd mention it just in case.
(Assignee)

Comment 35

15 years ago
I don't think it needs to change, it just denotes the Mozilla suite for
Applescript and I don't think we'd want to have different suites between
Seamonkey and Firefox. I hope sfraser will shout at me if I'm wrong :-).
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Updated

15 years ago
Flags: blocking-aviary1.0PR?
You need to log in before you can comment on or make changes to this bug.