Last Comment Bug 221783 - <wizard>'s buttons have no access keys
: <wizard>'s buttons have no access keys
Status: RESOLVED FIXED
: fixed-seamonkey1.0, fixed1.8.1, polish
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla1.8.1
Assigned To: Vidar Haarr (not reading bugmail)
: John Morrison
Mentors:
Depends on:
Blocks: accesskey 320736
  Show dependency treegraph
 
Reported: 2003-10-10 04:26 PDT by Stefan Borggraefe
Modified: 2006-02-05 17:19 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
toolkit version 0.1 (2.63 KB, patch)
2005-09-15 15:23 PDT, Vidar Haarr (not reading bugmail)
no flags Details | Diff | Splinter Review
xpfe version 0.1 (3.66 KB, patch)
2005-09-15 15:24 PDT, Vidar Haarr (not reading bugmail)
neil: review-
Details | Diff | Splinter Review
version 0.2 (3.54 KB, patch)
2005-09-18 16:58 PDT, Vidar Haarr (not reading bugmail)
neil: review+
Details | Diff | Splinter Review
xpfe version 0.3 (3.65 KB, patch)
2005-09-19 06:51 PDT, Vidar Haarr (not reading bugmail)
vhaarr+bmo: review+
neil: superreview+
Details | Diff | Splinter Review
toolkit version 0.2 (2.98 KB, patch)
2005-09-19 07:00 PDT, Vidar Haarr (not reading bugmail)
asaf: review+
Details | Diff | Splinter Review
toolkit version 0.3 (2.91 KB, patch)
2005-09-28 02:52 PDT, Vidar Haarr (not reading bugmail)
vhaarr+bmo: review+
mconnor: approval‑branch‑1.8.1+
Details | Diff | Splinter Review

Description Stefan Borggraefe 2003-10-10 04:26:24 PDT
The buttons of the <wizard> element currently have no access keys. There should
be at least some for the "Next" and "Back" buttons. The "Cancel" and "Finish"
button probably fall under the category "Common elements that don't get
accesskeys" listed here:

http://www.mozilla.org/projects/ui/accessibility/accesskey.html

They can already be accessed via Return and Escape respectively.
Comment 1 Vidar Haarr (not reading bugmail) 2005-09-15 15:23:10 PDT
Created attachment 196251 [details] [diff] [review]
toolkit version 0.1

Adds accesskey to all wizard buttons, including Finish and Cancel.
Comment 2 Vidar Haarr (not reading bugmail) 2005-09-15 15:24:27 PDT
Created attachment 196252 [details] [diff] [review]
xpfe version 0.1

xpfe version of attachment 196251 [details] [diff] [review].
Comment 3 neil@parkwaycc.co.uk 2005-09-18 16:42:16 PDT
Comment on attachment 196252 [details] [diff] [review]
xpfe version 0.1

Comment 0 was correct, Finish and Cancel do not have access keys. Also, please
use accesskey-<type> like dialog.xml does for its properties.
Comment 4 Vidar Haarr (not reading bugmail) 2005-09-18 16:58:25 PDT
Created attachment 196601 [details] [diff] [review]
version 0.2

I presume you meant like this?
Comment 5 neil@parkwaycc.co.uk 2005-09-19 06:31:09 PDT
Comment on attachment 196601 [details] [diff] [review]
version 0.2

Yes but you still need empty accesskey-finish= and accesskey-cancel= entries in
the .properties files.
Comment 6 Vidar Haarr (not reading bugmail) 2005-09-19 06:51:11 PDT
Created attachment 196643 [details] [diff] [review]
xpfe version 0.3

Neil: Since I'm not sure who you'd like to sr this, I thought you could
re-assign the sr request, if that's OK :-)

I'll attach an updated toolkit patch shortly.
Comment 7 Vidar Haarr (not reading bugmail) 2005-09-19 07:00:58 PDT
Created attachment 196644 [details] [diff] [review]
toolkit version 0.2

toolkit version updated to Neils comments.
Comment 8 Vidar Haarr (not reading bugmail) 2005-09-26 00:22:40 PDT
Neil or Aaron: Could you help me check in attachment 196643 [details] [diff] [review]?

If your review is accepted for toolkit as well, maybe we can take attachment
196644 [details] [diff] [review] off mconnors radar?
Comment 9 neil@parkwaycc.co.uk 2005-09-27 02:24:10 PDT
Comment on attachment 196644 [details] [diff] [review]
toolkit version 0.2

Trying Mano for this, in case access key behaviour is platform-specific.
Comment 10 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-27 22:55:18 PDT
Comment on attachment 196644 [details] [diff] [review]
toolkit version 0.2

(Note it is indeed disabled on OS X; We do allow to turn on accesskeys though.)

>Index: toolkit/content/widgets/wizard.xml
>===================================================================

>+             var accesskey;
> #ifdef XP_UNIX
> #ifdef XP_MACOSX
>-            btn.setAttribute("label", this._bundle.GetStringFromName("button-"+aName+"-mac"));
>+             btn.setAttribute("label", this._bundle.GetStringFromName("button-"+aName+"-mac"));
>+             accesskey = this._bundle.GetStringFromName("accesskey-"+aName+"-mac");
> #else
>-            btn.setAttribute("label", this._bundle.GetStringFromName("button-"+aName+"-unix"));
>+             btn.setAttribute("label", this._bundle.GetStringFromName("button-"+aName+"-unix"));
>+             accesskey = this._bundle.GetStringFromName("accesskey-"+aName+"-unix");
> #endif
> #else
>-            btn.setAttribute("label", this._bundle.GetStringFromName("button-"+aName));
>+             btn.setAttribute("label", this._bundle.GetStringFromName("button-"+aName));
>+             accesskey = this._bundle.GetStringFromName("accesskey-"+aName);
> #endif


decale and init |accesskey| inside the #ifdefs.


>+             if (accesskey) {
>+               btn.setAttribute("accesskey", accesskey);
>+             }

please remove single line brackets.

r=mano with those fixed.
Comment 11 Vidar Haarr (not reading bugmail) 2005-09-27 23:20:48 PDT
(In reply to comment #10)
> decale and init |accesskey| inside the #ifdefs.

I do not know what 'decale' means .. Spelling error for 'declare'?
By init, do you mean declare?

So you want 3x 'var accesskey = ...' ?
Comment 12 neil@parkwaycc.co.uk 2005-09-28 02:25:19 PDT
(In reply to comment #10)
>(Note it is indeed disabled on OS X; We do allow to turn on accesskeys though.)
Ah, so we need to provide them in case they get turned on, great.
>please remove single line brackets.
Bah, aaronlev introduced them into xpfe's dialog.xml :-( Mind you, he's not the
only culprit, you manged to check in both sorts for bug 284776 :-P

(In reply to comment #11)
>So you want 3x 'var accesskey = ...' ?
The point is that there will only be one in the end because of the #ifdefs.
Comment 13 Vidar Haarr (not reading bugmail) 2005-09-28 02:52:20 PDT
Created attachment 197682 [details] [diff] [review]
toolkit version 0.3
Comment 14 Vidar Haarr (not reading bugmail) 2005-09-28 02:53:42 PDT
(In reply to comment #12)
> (In reply to comment #11)
> >So you want 3x 'var accesskey = ...' ?
> The point is that there will only be one in the end because of the #ifdefs.

Yes, I realize that, I was just confused about 'decale'.

I'm not sure who could sr ?
Comment 15 neil@parkwaycc.co.uk 2005-09-28 16:36:21 PDT
Mano, please double-check the patch and check it in for Vidar.
Comment 16 Mano (::mano, needinfo? for any questions; not reading general bugmail) 2005-09-29 01:16:57 PDT
mozilla/toolkit/content/widgets/wizard.xml  1.24
mozilla/toolkit/locales/en-US/chrome/global/wizard.properties 1.5
mozilla/xpfe/global/resources/content/bindings/wizard.xml 1.25
mozilla/xpfe/global/resources/locale/en-US/mac/wizard.properties 1.4
mozilla/xpfe/global/resources/locale/en-US/unix/wizard.properties 1.2
mozilla/xpfe/global/resources/locale/en-US/win/wizard.properties 1.2
Comment 17 Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2005-12-14 08:28:30 PST
Comment on attachment 196643 [details] [diff] [review]
xpfe version 0.3

First a=me
Comment 18 Ian Neal 2005-12-14 09:12:38 PST
Comment on attachment 196643 [details] [diff] [review]
xpfe version 0.3

a=me for SM1.0b on SM only part of code, 2nd needed one - Horray!
Comment 19 neil@parkwaycc.co.uk 2005-12-14 09:40:55 PST
SeaMonkey-only portion of patch checked in to the 1.8 branch.
Comment 20 Robert Accettura [:raccettura] 2005-12-18 13:03:53 PST
Would someone take a look at bug 320736.  Possibly a regression from this bug.
Comment 21 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-02-05 17:17:28 PST
mozilla/toolkit/content/widgets/wizard.xml;                    1.23.2.2;
mozilla/toolkit/locales/en-US/chrome/global/wizard.properties;  1.4.8.1;

Note You need to log in before you can comment on or make changes to this bug.