Bad accesskey (button "Submit Report")

RESOLVED FIXED

Status

Other Applications
Reporter
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: JasnaPaka, Assigned: raccettura)

Tracking

(Blocks: 1 bug, {fixed1.8.1})

Trunk
fixed1.8.1
Dependency tree / graph
Bug Flags:
blocking-seamonkey1.0 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051218 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051218 Firefox/1.6a1

There is a bad accesskey in Reporter. First window of wizard, button "Submit Report > (N)".

Reproducible: Always

Steps to Reproduce:
1. Choose Help -> Report Broken Web Site.
2. There is a bad accesskey. See attachment.
3.
(Reporter)

Comment 1

12 years ago
Created attachment 206259 [details]
Screenshot
(Assignee)

Comment 2

12 years ago
Possibly fallout from 320736.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
I guess there needs to be an addition here:
<http://lxr.mozilla.org/seamonkey/source/extensions/reporter/resources/content/reporter/reportWizard.js#124>
Like:
reportWizard.getButton('next').accesskey = strbundle.getString("submitReport.accesskey");

And then add that property ('submitReport.accesskey') to reportWizard.properties.
(Assignee)

Comment 4

12 years ago
Sorry, should have been bug 221783.

I'd rather not patch until I find where it's regressed.
(In reply to comment #4)
> Sorry, should have been bug 221783.
> 
> I'd rather not patch until I find where it's regressed.

Hm?

<wizard> default buttons now have access keys assigned by the widget. You override the default label but not the default access key.
(Assignee)

Comment 6

12 years ago
Reason I say that is I tried the same thing you just posted about 2 days ago, and didn't work.  Since it's not truly 'broken' this hasn't been high prority just yet (hence no bug even).
Version: unspecified → Trunk
I don't see why it shouldn't work -- that would be a bug.

Maybe change <http://lxr.mozilla.org/seamonkey/source/toolkit/content/widgets/wizard.xml#370> to |if (accesskey && !btn.accesskey)| or similar.
(In reply to comment #6)
> Reason I say that is I tried the same thing you just posted about 2 days ago,
> and didn't work.

Did you try setting the attribute instead of using the property? IIRC the accesskey property doesn't work that great.
(Assignee)

Comment 9

12 years ago
*** Bug 318129 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Flags: blocking-seamonkey1.0?

Comment 10

12 years ago
Not blocking a release on this.
The item is working and accessible, it's just a minor UI glitch. Additionally, it's UI that most of our users probably won't see (though I hope people will start using it more and more).
And, BTW, noone told if it's even happening on branch(es)...
Flags: blocking-seamonkey1.0? → blocking-seamonkey1.0-
(Reporter)

Comment 11

12 years ago
(In reply to comment #10)
> And, BTW, noone told if it's even happening on branch(es)...

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060112 SeaMonkey/1.0b

Same problem.

(Assignee)

Comment 12

12 years ago
Created attachment 208661 [details] [diff] [review]
Patch

This should do it.
(Assignee)

Updated

12 years ago
Attachment #208661 - Flags: review?(gavin.sharp)
Comment on attachment 208661 [details] [diff] [review]
Patch

r=me
Attachment #208661 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 14

12 years ago
Fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Assignee)

Updated

12 years ago
Blocks: 315750
This patch is needed on the 1.8 branch now that bug 221783 landed there.
Whiteboard: [checkin needed (1.8 branch)]
(Assignee)

Updated

12 years ago
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
You need to log in before you can comment on or make changes to this bug.