no scrolling with synaptics touchpad

VERIFIED DUPLICATE of bug 146962

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 146962
15 years ago
15 years ago

People

(Reporter: Mathias Wahlin, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

Touch pads on laptops has a scroll feature when using the synaptics touchpad
driver. This feature doesn't work in Firebird.

The problem exists in Windows ME as well as Windows XP, currently using version
5.7.1.0 of the Synaptics TouchPad driver, but it's the same in older versions as
well.

The problem exists on at least two different laptops. 

My first version of Firebird was (Phoenix) 0.5 and the problem has always
existed for me.

Reproducible: Always

Steps to Reproduce:
1. Open a website with much text
2. Try to scroll using the right/bottom edge of the touchpad
3.

Actual Results:  
No scrolling occurs.

Expected Results:  
It should scroll using the vertical/horizontal scollbars, like IE does on the
same computer.

I'm using the default theme. Problem exists both on classic windows such as
win9x as well as on win xp with windows themes.

My guess is that there is a problem with the scroll bar association, I think the
touchpad uses the scroll bars directly (the pointer moves over to the scroll
bars when scrolling and then back again) instead of sending
WM_HSCROLL/WM_VSCROLL directly to the app, but I can't confirm this. Are the
scrollbars associated with the browsing window using the window styles when
creating the window or are they put there manually and linked to the scrolling
that way?

This is a big problem for me, I can't use firebird on my laptop without that
handy scrolling feature.

*** This bug has been marked as a duplicate of 146962 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
QA Contact: mpconnor
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v.
you need to upgrade your touchpad driver.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.