Closed Bug 222156 Opened 16 years ago Closed 16 years ago

Internet Keywords: http://localhost:910 does not go to "localhost"

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 184433

People

(Reporter: sdstern, Assigned: darin.moz)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

In the process of configuring SWAT on my Linux server, I found that

http://localhost:910/

maps to

http://www.netbreakthroughs.com/

The same happens when I use that address on my Windows PC with Mozilla.

BUT, http://127.0.0.1:910/ returns "page contains no data".

Note: My hosts file does contain a localhost entry for 127.0.0.1

Mozilla Firebird 0.7 20031007

Reproducible: Always

Steps to Reproduce:
1.  enter http://localhost:910/
2.
3.

Actual Results:  
Went to 
http://www.netbreakthroughs.com/

Expected Results:  
displayed content from local SWAT service
dupe of bug 164802 : see bug 164802 comment 6. 

Reporter, if you're using a proxy-server, make sure that "localhost, 127.0.0.1"
is filled in the 'no proxy for' field.

*** This bug has been marked as a duplicate of 164802 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
I am not using any http proxy and /etc/hosts contains

127.0.0.1   localhost

It seems to me that attempting to resolve localhost to localhost.com is
incorrect behavior.
Firebird isn't resolving to localhost.com (as is Mozilla, see under Preferences
-> Navigator -> Smart Browsing). If you type an unresolvable URL, you get a
google "i'm feeling lucky" result for that string. www.localhost.net.au is the
first in that list ( see http://www.google.be/search?q=localhost ).

If you don't like this (I fully agree that this sucks) then set
pref("keyword.enabled", false); in your prefs.js and you won't see it happen any
more. See bug 184433.
REOPEN:
Need to find correct dupe.
Status: RESOLVED → UNCONFIRMED
Component: Networking: HTTP → Location Bar
QA Contact: httpqa → benc
Resolution: DUPLICATE → ---
Summary: http://localhost:910 does not go to "localhost" → Internet Keywords: http://localhost:910 does not go to "localhost"
Steven: 
Can you describe what SWAT is?
Also, is there a web server running on your system when this happens?

You might be reporting bug 178123, or the problem might be something else.
Component: Location Bar → General
Product: Browser → Firebird
Version: Trunk → unspecified
I also get this while using ssh port forwards, if I close my ssh connection, I
end up getting redirected to "www.localhost.net.au"
Which maps, to the first google result for "localhost"

I think that the behavior of running google's "I am feeling lucky" on something
that looks like a uri is not right.

I think that typing "localhost:8000/someurl" should (maybe) try that, but typing
"http://localhost:8000/someurl" should just fail.

The annoyance in this behavior is that doing a typo in a hostname will trigger a
redirect and the "back" button can not be used to correct what was entered.
boozai: which version of mozilla or firebird are you using?
I had this problem from day 1, but never got a chance to enter a bug in the
database for that.

Using the 0.8 release on windows 2000 and XP, with mozillabar installed.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Nicolas
boozai: please try a nightly build instead, where this bug should be fixed (as
bug 184433, which I suspect this is a duplicate of)
I just tried on nightly
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040228
Firefox/0.8.0+

and I confirm this is fixed.
thank you. marking as duplicate of bug 184433, then.

*** This bug has been marked as a duplicate of 184433 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
V/dupe.
Thanks for the updates.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.