Ctrl+K for Search conflicts with Linux/KDE shortcut for Clear

RESOLVED DUPLICATE of bug 216930

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 216930
15 years ago
12 years ago

People

(Reporter: Jay Knight, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Ctrl+k is the shortcut to focus the toolbar search.  However, this seems to
conflict with a linux/kde shortcut for clear.

To Reproduce:
1.  while focus is on content area, but not a text field, type ctrl+k
2.  Notice that search bar has focus... good
3.  Now focus a textfield (address bar will do)
4.  Type ctrl+k again

Expected Results:
Search Bar gets focused when shortcut is typed

Actual Results:
Search Bar does not get focus on shortcut if a text field does.

Comment 1

15 years ago
Not specifically kde.

I'm not sure that it's a good idea to overide the standard key bindings of the
OS/system.

Updated

15 years ago
Summary: ToolBar search shortcut conflict → Ctrl+K for Search conflicts with Linux/KDE shortcut for Clear

Comment 2

15 years ago
Yes, I agree that sucks
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

15 years ago
Bug 72352 suggests making this sort of thing into a pref.

*** This bug has been marked as a duplicate of 72352 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
reopening
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

15 years ago
> reopening

That's pretty obvious, but can you please explain why?

If you don't think this is a dupe of bug 72352 then how about bug 218224? which
is a dupe of bug 216930 (which is currently marked as a dupe of 72353). There
are more out there if you search hard enough (but all resolved as dupes).

Comment 6

15 years ago
I'm resolving this as dupe again since there hasn't been any further objection.
Am resolving as dupe of bug 216930 because that is specifically ctrl-K in
Firebird so there can't be any argument about its duplicate nature. 

*** This bug has been marked as a duplicate of 216930 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.