Don' use sheet for the preferences dialog

VERIFIED DUPLICATE of bug 206651

Status

()

--
major
VERIFIED DUPLICATE of bug 206651
16 years ago
13 years ago

People

(Reporter: manfred, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Don't use a sheet for the preferences dialog. A sheet is intended for document
(window) modal dialogs. The preferences dialog is neither document modal, since
it applies to the whole application, nor is there a good reason for it to be
modal at all.
Make the preferences dialog a modeless dialog window.

Reproducible: Always

Steps to Reproduce:
1. Menu Mozilla Firebird->Preferences
Actual Results:  
Preferences sheet

Expected Results:  
Modeless preferences dialog window.

Comment 1

16 years ago
-> preferences + reassigning.
Component: General → Preferences
QA Contact: mpconnor

Comment 2

16 years ago
dupe of bug 206651. also see bug 222686

*** This bug has been marked as a duplicate of 206651 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified dupe.
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.