MacOS X Firefox Preferences Window Meta

VERIFIED FIXED in Firefox1.5

Status

()

P2
normal
VERIFIED FIXED
15 years ago
12 years ago

People

(Reporter: bugs, Assigned: bugs)

Tracking

unspecified
Firefox1.5
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

This bug lists numerous issues with the Preferences window in MacOSX Firebird:

- the window appears as a sheet dialog rather than as a modeless window
- the window has OK and Cancel buttons whereas preferences should be set immediately
- the button icons appear down the left of the window rather than across the top
as they should. 

These issues can be addressed with a redesign of the preferences FE and a
greater use of XBL to allow for platform differences.
-> me
Assignee: blake → bugs

Comment 2

15 years ago
welcome to the mac world, ben.  any chance you could look at some of the older
bugs first?  prefs work sorta okay right now.  :)

bug 222366 is concerning one of your points, not sure what you want to do with it.

Comment 3

15 years ago
Can the XBL be done within the skin or does it need to be outside? 

Something else to add to the list .. If you make pref window not modal, you'll
find it's named "Options" rather than "Preferences".
Status: NEW → ASSIGNED
Flags: blocking1.0+
Priority: -- → P2
Target Milestone: --- → Firefox1.0

Updated

15 years ago
Flags: blocking1.0+ → blocking1.0mac+

Updated

15 years ago
Depends on: 206651
Target Milestone: Firefox1.0 → Firefox1.0Mac

Comment 4

14 years ago
moving blocking1.0mac bugs to Firefox1.1 Target Milestone.
Target Milestone: Firefox1.0Mac → Firefox1.1

Updated

14 years ago
Summary: MacOS X Firebird Preferences Window Meta → MacOS X Firefox Preferences Window Meta

Updated

14 years ago
Blocks: 237584
fixed.(In reply to comment #0)
> This bug lists numerous issues with the Preferences window in MacOSX Firebird:
> 
> - the window appears as a sheet dialog rather than as a modeless window
> - the window has OK and Cancel buttons whereas preferences should be set
immediately
> - the button icons appear down the left of the window rather than across the top
> as they should. 

fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
*** Bug 269419 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
Flags: blocking-aviary1.0mac+
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.