[blocker]Changing COLSPAN or ROWSPAN attribute in a cell doesn't trigger redraw of table

VERIFIED FIXED in M13

Status

()

P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: cmanske, Assigned: karnaze)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
I'm not sure if this is layout or DOM - I'll let Troy decide.
Load the attached test file into viewer or apprunner.
Click on the buttons to change the COLSPAN or ROWSPAN of Cell 2 in the table.
The table doesn't redraw.
Other buttons included in the test file confirm other attributes are working
better, although setting the body background color still doesn't redraw the
the entire view correctly (this is covered by bug 1886).
(Reporter)

Comment 1

19 years ago
Created attachment 3677 [details]
Test changing COLSPAN, ROWSPAN attribute on a table cell

Updated

19 years ago
Assignee: troy → karnaze
Component: Layout → HTMLTables

Comment 2

19 years ago
Changing component to HTML Tables
(Reporter)

Updated

19 years ago
Summary: Changing COLSPAN or ROWSPAN attribute in a cell doesn't trigger redraw of table → [blocker]Changing COLSPAN or ROWSPAN attribute in a cell doesn't trigger redraw of table
(Reporter)

Comment 3

19 years ago
Marking as blocker for beta table editing work and adding Steve to CC.

Comment 4

19 years ago
charley also sez:
Note that this is a regression - it worked when I did initial table editing. I
think it crept in sometime after 12/10.
(Reporter)

Updated

19 years ago
Blocks: 21024
(Reporter)

Comment 5

19 years ago
Created attachment 3729 [details]
Sample table for testing row and column insert with COLSPAN and ROWSPAN > 1
(Reporter)

Comment 6

19 years ago
Using the 12/22/99 attachment, here is an example of bad table layout as a
result of not responding the the changed rowspan:
1. Edit the 12/22 sample file
2. Place caret in cell containing "7"
3. Execute menu command Table | Insert | Row Below
See the bad table layout!
Execute Debug | Test Table Layout to show debug information: notice that the
cell with the "6" did have its rowspan changed to 4, as it should.
Note also that you can click in various cells in the table and type or resize
the window, but none of these actions cause the table to redisplay correctly.
If you us File | Save As to save the file locally, then reload that file,
the table will display correctly.

You can also test inserting a "column before" by placing caret in the cell with
"7" and use Table | Insert | Column before.
The cell with the "2" increases its COLSPAN, but again the table doesn't
redraw correctly.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M13
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
Fixed with latest checkin.
(Assignee)

Updated

19 years ago
Status: RESOLVED → REOPENED
(Assignee)

Comment 8

19 years ago
I fixed the 1st attachment but didn't fix the 2nd. Reopening.

Updated

19 years ago
Resolution: FIXED → ---

Comment 9

19 years ago
Clearing FIXED resolution due to reopen.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
The 2nd attachment was fixed with 1/15 changes.

Updated

19 years ago
Blocks: 24206

Comment 11

19 years ago
Fixed in the Feb 22 build.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 12

19 years ago
rowspan/colspan=0 now only works according to HTML 4 in strict mode. There were 
pages relying on the behavior where a value <= 1 became 1.

Updated

19 years ago
No longer blocks: 24206
You need to log in before you can comment on or make changes to this bug.