'Open link in new window' option on right-click does not work.

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: biswapesh_chatterjee, Assigned: vidur)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
System: Build 1999121915 on WinNT 4 (SP 5).
Overview: Right-clicking on a link and choosing 'Open link in new window' does
not work in http://www.zdnet.com/. Instead a Javascript exception is thrown on
the console.
Test Case: Go to http://www.zdnet.com/. Right click on any link. The context
menu appears. Choose 'Open link in new window'.
Expected Result: A new window should open with the clicked URL.
Actual Result: The document jumps on right-clicking and part of the link turns
red. On choosing 'Open link in new window', nothing happens, except the
following exception being thrown in the console (I've attached some pre- and
post- text to the actual error message):
<<<<<<<
Document http://www.zdnet.com/ loaded successfully
Document: Done (338.937 secs)
12606560 : Focus occurred on: Window with an HTML doc (happens twice)
12606560 : Blur occurred on: Window with an HTML doc (happens twice)
12606560 : Focus occurred on: Window with an HTML doc (happens twice)
X Pos: 466
Y Pos: 514
JavaScript Error: TypeError: this.target has no properties
URL: chrome://navigator/content/nsContextMenu.js
LineNo: 155

12606560 : Focus occurred on: A Focusable DOM Element
JavaScript Error: TypeError: contextMenu has no properties

JavaScript Error: TypeError: contextMenu has no properties

12606560 : Blur occurred on: A Focusable DOM Element
>>>
Left-click on the links works fine.

Comment 1

19 years ago
Created attachment 3686 [details]
testcase; simplified HTML showing bug

Comment 2

19 years ago
Created attachment 3687 [details]
testcase; A HREF inside LAYER or ILAYER; context 'Open New' fails

Comment 3

19 years ago
In the simplest case, this demonstrates the error:

<LAYER>
<a href="">Judge won't release Naughton</a>
<a href="">PC makers rolling out 800MHz PIIIs</a>
</LAYER>

Comment 4

19 years ago
... I was using 1999122008 WinNT SP4 for the test cases and I have the same
console messages with the test cases as was reported earlier.

Updated

19 years ago
Whiteboard: [TESTCASE]

Updated

19 years ago
QA Contact: nobody → elig

Comment 5

19 years ago
3jrgm@qlink.queensu.ca, might you consider this to be a JavaScript problem, or a
layers incompatibility problem, or <fill in the blank>? [so that the bug can go
to the appropriate engineer] Thanks!

Comment 6

19 years ago
Not javascript per se. I would guess DOM since the LAYER container is what
causes the the <A HREF> to fail, so perhaps vidur to start (but it might be
a problem in the events propagating). [How you doing, by the way, elig?]

Updated

19 years ago
Assignee: nobody → vidur

Comment 7

19 years ago
Tossing over to vidur; thanks! [me? doing okay. of course, pleasantly surprised
to see your reappearance! ;-]
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
Fixed on 12/22/1999. Had to remove incorrect attempt to create special script
objects for LAYER and ILAYER elements.
(Assignee)

Comment 9

19 years ago
*** Bug 22671 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: elig → sairuh

Comment 10

19 years ago
Contextual menu-like issue; QA assigning to sairuh for verification.
Status: RESOLVED → VERIFIED
works for me --verified using 2000011008 comm. bit on winNT.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.