Password Manager should automatically display autocomplete widget for pages/sites where user has saved multiple logins

RESOLVED DUPLICATE of bug 376668

Status

()

Toolkit
Password Manager
--
enhancement
RESOLVED DUPLICATE of bug 376668
14 years ago
10 years ago

People

(Reporter: David P James, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.6 -
blocking-aviary1.0 -
blocking-aviary1.5 -
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
With the switch to the new password manager we no longer display a pop-up
presenting logins for sites where the user has multiple logins saved. The user
now has to start typing one of those logins or use the down arrow to call up the
autocomplete widget. The problem is that the user may not know that she can do
that. Pierre Chanial suggests in bug 173565 comment #11 that we automatically
display the autocomplete widget in such cases. Jesse Ruderman came up with much
the same idea which I described in bug 220734.
(Reporter)

Comment 1

14 years ago
*** Bug 216541 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

14 years ago
*** Bug 222367 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
Frankly I've been astonished at the "Resolved" comments I've read in
relationship to this issue?!?! especially as some haven't even tested the new PM
with Hotmail? if you haven't tried it at Hotmail, how can you give an opinion as
to whether a problem does or doesn't exist??  I can perhaps guess at where your
indifference towards Hotmail comes from, but you must realise there's a hell of
a lot of people have Hotmail accounts out there!

I've tried the suggestion...

------- Additional Comments From steffen.wilberg@web.de  2003-10-17 07:59
-------
Start typing in your username. Password Manager displays a list with your stored
usernames as soon as it can distinguish them. Does this help?
Moving to password manager component and reassigning.
------- 

This DEFINATELY does not work on Hotmail!!  I've tried it on another site and
the "new" method of bringing up saved passwords does work, but NOT with Hotmail!
(Have I missed something? or is the new way the PM works a well kept secret?)

Not sure what you guys are doing? it seems to be 1 step forward 2 steps back?!?!
Ever heard of the saying?... "if it ain't broke don't try to fix it!"

It's fine changing things if you feel you can improve things, but I fail to
follow what improvements you were trying to bring in changing the Password Manager?

You seem to have changed things for no other reason than to make the Firebird
Password Manager more like the Internet Explorer PM??  If the IE PM worked
better ok make the change, but I don't think it does (and I've NEVER met anyone
else who does either!) and as the Firebird PM worked in such a simplistic self
explanatory way, it's not as if people new to Firebird wouldn't know how to use
it? (PLUS IT USE TO BE RELIABLE!)

So aside from the Hotmail bug, the way the new Password Manager "works" (or not
as the case may be...) sucks big time!  In my opionion put things back as they
were and use your talents, time & experience on more worthy problems with
Firebird (you could dump bleedin' Mozilla for a start, you've hit the ground
running with Firebird why waste your time on a lame duck?)  I've also found that
on sites that do show some success/support with the new style PM, that it can
sometimes take mutliple clicks, deleting of text in the username box, the down
arrow to make the PM kick in!! (that is often a combination of these methods is
required to wake the PM up?) so even on sites that your PM seems to support it
doesn't ALWAYS work!?!

Sorry, tried to be as constructive as possible. :)

Thanks for your efforts

Comment 4

14 years ago
Hit escape twice.  Then does typing bring up the autocomplete?  

Comment 5

14 years ago
Thank you for your suggestion of...

------- Additional Comments From 9quawbieby0001@sneakemail.com  2003-10-17 17:08
-------
Hit escape twice.  Then does typing bring up the autocomplete?
-------

Hitting the escape key twice then using the down arrow does indeed seem to work
on sites other than Hotmail.  I still think the previous method of working was
FAR SUPERIOR to this!!  This new method has introduced completely un-necessary
clicks & keystrokes!?!?

The Hotmail bug is still present.

Cheers

Comment 6

14 years ago
You don't need to quote people.  Its all here on the bug.

I commented about hitting escape twice on bug 220734
I found that hitting it the first time actually pasted some other form data into
the blank.  I would probably say that 220734 is a dupe of this.
(Reporter)

Comment 7

14 years ago
Hoca:

This bug is about replacing the now-gone focus-stealing pop-up of the old
password manager with the an automatic opening of the autocomplete widget in
cases where the user has multiple login ids. When this is fixed you'll be able
to select the login id from the autocomplete dropdown without ever having to
type anything.


Bug 220734 is about the specific case of the form attribute value="" causing
problems of its own. Chances are fixing this bug will fix that one, but not
necessarily.

Hotmail.com uses autocomplete="off" in the password field and that seems to
create problems of its own (at least for me on Linux). Likewise, Yahoo doesn't
get filled out automatically either. But those would both be separate issues/bugs.

Comment 8

14 years ago
Opening the autocomplete dropdown for the username field immediately on page
load would be weird, especially if you would normally have to scroll down to see
the login field.  But opening it the autocomplete dropdown when the username
field gains focus (by the user clicking, by textbox.focus(), etc) would be nice.

Comment 9

14 years ago
This bug affects other pages, including iWon and Excite Mail, both of which seem
to have autocomplete=off, one for login name, one for pw field.

I also want to point out that 99% of the times, if someone goes to a page with a
login form, even if it's near the bottom of the page, they would want to log in.
I can't think of a time when that's NOT what I do. So it's annoying to have to
click in a field to get the autocomplete. But hey, if you're going to do that
I'm not going to make a fuss about it because the current situation is so much
worse.

Comment 10

14 years ago
Assuming that you guys ditched the password dialog because it was 
intrusive or disruptive to the browsing experience, you could use the status bar,
much like Firebird does when an 'alternate stylesheet' is available.
(Go to http://www.w3.org/Style/Examples/007/alternatives.html and note the 
crayon box in the left side of the status bar. click it, a list appears of
alternates.) 

Likewise an appropriate icon could show up when login options are available. It 
wouldn't interrupt the user and it would easily provide all the available login
options. 
(Reporter)

Comment 11

14 years ago
> This bug affects other pages, including iWon and Excite Mail, both of which
> seem to have autocomplete=off, one for login name, one for pw field.

This bug doesn't affect that. Autocomplete=off disables the Password Manager,
period. To enable Password Manager on such sites you have to employ Jesse's
remember password bookmarklet. See also bug 222367.
http://www.squarefree.com/bookmarklets/forms.html#remember_password

Comment 12

14 years ago
Though it may be closely related, as I too do not see the password completor
working until I start typing, but also FB doesn't prompt for the password
managers password until late in the process of either saving, or needing a
password for lookup.

This has been busted work weeks, any news on a nightly build to resolve this?

Updated

14 years ago
Flags: blocking0.8?
(Reporter)

Updated

14 years ago
Blocks: 227632

Comment 13

14 years ago
I guess I have been posting comments in bug 220734 when they should have been
posted here.  The form that I'm working on
(http://ipac.kcls.org/ipac20/ipac.jsp?profile=dial--1--1--1&menu=account)
doesn't have form attribute value="", so I guess this is the bug I should be
watching.

See my comments in bug 220734 for some a way to enable/disable this bug in
Firebird 0.7.   Also this bug has regressed further in the 0.8 test build
(03.01.04 - 02:59:00).

Comment 14

14 years ago
I don't think this is important enough to block 0.8, especially because
autocomplete is horked right now.
considering that this is by design, I don't think this comes anywhere close to
blocking material.
Flags: blocking0.8? → blocking0.8-

Comment 16

14 years ago
"by Design"?  If that is the case, I respectfully believe the design needs to be
recosidered.

Currently with this bug (design), I have to keep a written list of the four (1
for each member of my family) 8-10 digit numbers near the computer just to go
and check on my holds at our library.  Once I type in the id, the passwords are
recalled correctly (that part of the design works great.)  Somehow, a list of
passwords need to be displayed in some obvious fashion.

Another thing to note is my wife will not switch to the next version, if this
bug isn't fixed.  I suspect that there are a lot of people who will be very
annoyed if this bug shows itself on their next "upgrade".  This may not be
serious enough to block 0.8, but please don't let it go another release cycle.

Is there anything I can do to help characterize this bug further?

Does anyone know if this bug present in Mozilla 1.6?

Comment 17

14 years ago
You should get a dropdown of remembered entries just by pressing the down arrow
while the cursor is in the box.

Comment 18

14 years ago
That is... in theory.
In theory you should get a dropdown of remembered entries just by pressing the
down arrow while the cursor is in the box.
But it's not so... at least not in latest 0.8 trunk 
( Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040114 Firebird/0.7+ )

Only some times, maybe like 10% of the cases, do I get such remembered entries
options. Most times they never appear, I am forced to remember and type my ID's,
then, and only then, passwords are automatically filled in.


On the other comment, as Kipp Howard's comment said... that it might be a
"Design Bug", I agree. Maybe if the "widget to autocomplete passwords" is not a
popup, then it should have a visible down arrow in the screen. Most users
(except us advanced ones) would never even think of such a thing as "trying to
use their keyboard down arrow".

Comment 19

14 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040114
Firebird/0.7+

Comment 20

14 years ago
> Maybe if the "widget to autocomplete passwords" is not a
> popup, then it should have a visible down arrow in the screen. Most users
> (except us advanced ones) would never even think of such a thing as "trying to
> use their keyboard down arrow".

Um, that's how IE does it.  It autocompletes the username if someone selects it
and fills in the matching password if you've told it to remember it.  Maybe
people would find this much more convenient than a pop up dialog.
(Reporter)

Comment 21

14 years ago
Respectfully, I'm not convinced that what we currently have is "by design". More
like "it'll do for now until we finish more urgent work". For evidence, I
re-refer everyone to Pierre's comment #11 bug 173565 where the issue clearly is
raised but is regarded as being relatively insignificant.

CCing based on bug 173565 comment #21

Comment 22

14 years ago
I's been ages since I used IE, just used it a little to see what they do in
these cases. I see that when I have a login remembered by it, when I double
click inside the field it automatically displays the login options so I can
chose among them. No need to use the down arrow. That's a nice feature, I must
confess.

Added to that, as it currently is in Firebird, if when you only have one login
it is automatically prefilled, you end up with a great password feature.


------ currently:
- When there are two or more remembered logins, nothing is prefilled (correct,
but...) and the down arrow dooes not always work (just 10-20% average in my
case). So there's a bug in current implementation of the down arrow.

- Similarly, one could ask oneself if this is the way it should work (by design)
anyhow. For user intuitiveness, if there is more than one login, the down arrow
technique (alone) is not the best (in my opinion). I would go with something
more visual. I used to like the popups, but now I'd go for IE's technique, only
that with one click instead of a doble click inside the login area.

Comment 23

14 years ago
Has anyone considered reinstating the old logon popup, but in the sidebar?
A pref could be added to disable it.
I think clicking in the field should trigger what the down-arrow does.  It 
would be the simplest and most obvious solution.

The sidebar won't happen, it doesn't belong in the sidebar concept, and forcing 
multiple layouts of the same page won't be nice for perf.

Comment 25

14 years ago
Created attachment 142698 [details]
Visual proposal for a password widget activator.

I'm attaching a visual proposal for what could be a way to visually aid in
activating a widget to show available passwords.

It has two examples:
 - 1. Small on the right upper corner.
 - 2. Normal slector size half transparent to avoid confusing with other type
of form.

I would go for option #1 as it would be less likely to confuse people, as no
forms have a clickable area similar to that one.

Comment 26

14 years ago
If we're going for a visual widget, perhaps it should match that of the search
bar (the small black arrow that appears to be in some 0.7+ nightlies and 0.8
onwards.

Comment 27

14 years ago
I read through all the previoius comments and one thing I didn't understand was
why the Password Manager was changed to begin with.  What did changing the PM
get us?

I'm a Mozilla 1.4 user and just downloaded Firefox to compare.  As this bug
notes, in Mozilla 1.4 when I go to my brokerage account where I have 5 different
accounts, as soon as the page loads I'll get (sometimes....the master password
popup, followed by...) a popup in which I can select the correct account, and
then click submit or hit enter to login.

In Firefox 0.8, I go to the page and get nothing.  If I type a number that
doesn't match any of the first digits in any of my account numbers, I get
nothing at all.  If instead I type a number that matches any of the first digits
of my account numbers, then I get a pull down list of the account numbers that
matched.  And lastly, if instead I simply hit the down arrow key then I get the
complete list of account numbers.  (Of course, I didn't know this last down
arrow thing until reading this bug text...)

Anyway, back to my original thought....was this behavioral change between
Mozilla 1.4 (which I realize is an old version) and Firefox 0.8 on purpose?  Or
an inadvertent change?  If inadvertent...it'd be nice for it to be restored to
its previous (expected and intuitive) behavior.  If deliberate...what was improved?

Thanks.

Comment 28

14 years ago
It is more IE-like.

Comment 29

14 years ago
It was removed because someone has decided to remove all popups from Firefox 
without necessarily having something to replace them.

Comment 30

14 years ago
And being more IE-like #28 is supposed to be good?  Bah!  If I wanted the MS
****, I'd use it but as far as this goes, this loss of functionality has been a
royal pain and doesn't seem to be gaining any forward momentum.  As for the
pop-up removal #29, that is rather one dimensional as there still needs to be
the popups for the master password and since when was it determined that all
pop-ups are bad?  They serve a specific purposes and need and these type of
pop-ups are very different than advertisting abuse...
Users don't read dialogs.  Its been established in numerous studies for 
usability etc.  Use of dialogs is intentionally being restricted to criticial 
security/dataloss scenarios whenever possible.  The point is to make it such 
that if you do get a dialog, its probably important enough to read.  

If simply clicking in the field/on a widget in the login field gave the option 
to select one of the stored logins, I see nothing wrong with that as your 
intent is obviously to log in.  Some sites, however, might have useful content 
without logging in and I might not want to log in on a given visit.  Having an 
automatic dialog in that scenario is a usability loss.

Comment 32

14 years ago
And the password manager dialog box doesn't qualify as 'its probably important
enough to read' then I don't know what would because an event is happening, the
user is logging in, so a dialog about which account and password to use, appears
to be as seamless and tightly linked as you can get and yes, 'Important enough
to read.'

As for those sites where one chooses to remain anonymous, they can cancel the
box and, if that is the majority of their browsing is anonymous, then let them
disable the function of the password manager.  At present, however, the password
manager has been neutered and is useless.

Comment 33

14 years ago
I'd just like to further Mike's comments, which I agree with, to say that with 
the old system, a site loading in the background would still show the dialog, 
interrupting whatever you were currently doing.

Not only do users not read prompts, the fact that it steals focus is (or was) 
far worse and often irritating.

I don't think anyone will argue that the current system is perfect, but 
currently you can either use 0.6.1 or live with it (as I have chosen to) until 
0.9 or 1.0 depending on how things go. This really must be resolved by 1.0 at 
the latest, along with the other major password manager functionality bugs.

Updated

14 years ago
Flags: blocking1.0?
You can hit the down arrow on an empty field and get the available logins. 
Flags: blocking1.0? → blocking1.0-
(Reporter)

Comment 35

14 years ago
*** Bug 245127 has been marked as a duplicate of this bug. ***

Comment 36

14 years ago
They should at least add an option to allow the Select User widget to be usable.
It is still fully functional in the normal Mozilla builds up to 1.7rc2 so far,
so their reasoning behind FULLY disabling is still null.

Comment 37

14 years ago
<<You can hit the down arrow on an empty field and get the available logins.>>
You can, but this requires you to use the keyboard.

If I select a bookmark or switch to another tab, my right hand is now on the
mouse, not over my "Down" key. When I click to focus the field, there is no way
for me to select from the list of available logins unless I press the down key,
or start typing, both of which require me to take my hand off of the mouse.

Instead of producing the effect shown in the first (and only) attachment, why
don't we simply drop down the list of users when the field is first focussed (by
keyboard or mouse)? I'll look into doing this now to find out the changes
required, but I haven't yet figured out how to produce a patch, so I'll just
paste my changes in here.

Comment 38

13 years ago
I just had an idea:

How about displaying available usernames in the right-click context menu's?
To avoid context menu bloat, only activate it when right-clicking on a
username/password field. BugMeNot does something like this, I think it's a good
idea.

Comment 39

13 years ago
I have to second comment #0 and comment #32.

Right now, with FF 1.0, there is *no way to tell the difference* between

- there are multiple logins and password manager is waiting on a keystroke

and

- password manager is broken, no logins have been saved, logins have been lost

I couldn't get any of the login popups to appear, so I came here intending to
report a bug.  To find that IE's craptacular braindead behavior is being
imitated is distressing.  I don't *want* to have to press extra buttons or click
on extra buttons.  The browser *knows* it needs to ask me to choose, so it
should just *ask*!

Comment 40

13 years ago
I agree with the previous post. The new behaviour is an improvement over the old
pop-up password manager in that it doesn't interrupt the application workflow,
but is a nightmare in everything else. Specially because it's not discoverable:
a user might never know that she can request Firefox to show all the stored
passwords.

Another important error is that it only works when the login field is empty. If
you select a password and then change your mind, the password manager will only
show the autocomplete entry for the current login. You have to manually erase
the text field to have the complete list of passwords shown again. A good
feature to have would be a "blank field" entry added to the end of the passwords
list.

There are several alternate implementations possible which are better than the
current one. I will analize them here now. Some have already been proposed,
others are new ones:

*** 1) Adding a dropdown arrow to the login field. This turns the text box into
a combobox.
Advantages: Its behaviour is similar to the URL bar (there's a good reason for
it to have a dropdown arrow. That reason is also a good one for passwords).
Simple and effective. It could solve the "wait until page is fully loaded" problem.
Disadvantages: it could collide with real combo boxes.

*** 2) Automatically open the password manager whenever the login field is focused.
Advantages: easy to program. This also could solve the "wait until page is fully
loaded" problem.
Disadvantages: non-standard behaviour. Can be intrusive because it's an
unexpected popup.

*** 3) Adding an icon in the status bar for the password manager. Similar to the
"RSS" and "Security" widgets.
Advantages: Accessible on demand (i.e. only when needed). This interface is
consistent with the other status widgets and would be easy to learn and use.
Disadvantages: I can't see any. This would be my preferred solution.

*** 4) Adding a toolbar button for the password manager. Similar to the Autofill
extension (http://autofill.mozdev.org/screenshots.html)
Advantages: Always accessible.
Disadvantages: Uses screen space; unless enabled by default, few people would
use it. But then it would add clutter to the inicial Firefox configuration.

*** 5) Turning the password manager into a "error bar" like those for the popup
blocker and the plugins & extensions instalation.
Advantages: very easy to discover. Easy access to the Preferences dialog.
Disadvantages: somewhat intrusive. It could be annoying to have it appearing at
every login page. All the same this is my second preferred solution.

Comment 41

13 years ago
*** Bug 276063 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.1?
*** Bug 281301 has been marked as a duplicate of this bug. ***
*** Bug 292713 has been marked as a duplicate of this bug. ***

Comment 44

13 years ago
(In reply to comment #43)
> *** Bug 292713 has been marked as a duplicate of this bug. ***

Is there any good solution for this case?

Comment 45

13 years ago
Requestng that OS be changed, if possible, to Windows. As I, somehow, appear to
have a pop-up showing my multiple logins under Linux.

Updated

13 years ago
Blocks: 163993

Updated

13 years ago
No longer blocks: 163993
this is an enhancement, not something missing from the intended design.  Not
going to block on this, but a safe patch would be considered.
Severity: normal → enhancement
Flags: blocking-aviary1.1? → blocking-aviary1.1-
Assignee: bryner → nobody
QA Contact: davidpjames → password.manager
Hardware: PC → All
Version: unspecified → Trunk
No longer blocks: 227632

Comment 47

12 years ago
*** Bug 312950 has been marked as a duplicate of this bug. ***
I never saw this problem, unless I had a code in userChrome.css that hides
autocomplete popups, e.g. this one: 
/* Block Pull Down Menu History  */
#PopupAutoComplete > .autocomplete-tree {display: none !important;}
But maybe I'm just lucky :?
Screenshot: http://img.photobucket.com/albums/v337/tamarix/firefox/example.jpg
Here also a screenshot Gmail:
http://img.photobucket.com/albums/v337/tamarix/firefox/gmail.jpg
But maybe I misunderstand the bug and the popup should appear without clicking
in the box.

Updated

12 years ago
Summary: Password Manager should display autocomplete widget for pages/sites where user has saved multiple logins → Password Manager should automatically display autocomplete widget for pages/sites where user has saved multiple logins

Comment 50

12 years ago
It appears that this problem has been fixe in FireFox 1.5 beta 2.  

I, personally, haven't had this problem for quite a while but my wife has been
experiencing the problem in FireFox 1.0.7 (and below) for a long time.  Last
week I upgraded FireFox to 1.5 beta 2 and my wife said that she is now getting
the password popup so it appears this bug has been fixed in FireFox 1.5 beta 2.

Is anyone else experiencing this bug in FireFox 1.5 beta 2?

Comment 51

12 years ago
This bug hasn't been fixed. See attachment 142698 [details] for a proposal of how the
interface will look when it is.

Comment 52

12 years ago
Sorry for bugspam, but I meant to add that if this bug was only intended to
cover comment 24, Firefox still requires a double-click before the autocomplete
entries are shown, rather than automatically displaying the entries when the
field is clicked on. 

This bug should probably remain open for that issue and/or the enhancement shown
in attachment 142698 [details].

Comment 53

12 years ago
Let me restate the regression fix that my wife is seeing.  It may not be what is
proposed, but it is working a bit better than it was in 1.0.7.

When she goes to https://catalog.kcls.org/patroninfo and needs to enter a card
number from a list of 4 that she has saved, a list of card numbers shows up if
she clicks in the field labeled "Library Card Number" while it has focus
(meaning double click if it doesn't have focus).  This means that she doesn't
have to remember (retype) the card number to get the memorized password.

In the past, after she typed in the card number, the password manager would
supply the correct password.  No drop down with a list of card numbers would
appear at any time.

Based on the original description of this bug, this issue has not been resolved,
it is just that 1.5 beta 2 has fixed a regression that was even worse than the
original description.  Oh well, there is at least some progress.

Comment 54

12 years ago
With Firefox 1.5 on Windows XP, the following problem persists: I have found no way of choosing a username among multiple alternatives, regardless of whether the form field has the attribute 'value=""' (discussed in bug 220734). I have to type the entire username, after which the associated password is autocompleted. Hitting the down arrow (up front or after typing a partial username) does nothing.

I have repeatedly attempted to migrate from Mozilla to Firefox, but have always ended up going back largely because of this annoyance.

Comment 55

12 years ago
Well it works by default, so Bugzilla is the wrong place for your problem. If Please visit http://forums.mozillazine.org for support.

Comment 56

12 years ago
(In reply to comment #54)
> With Firefox 1.5 on Windows XP, the following problem persists: I have found no
> way of choosing a username among multiple alternatives, regardless of whether
> the form field has the attribute 'value=""' (discussed in bug 220734). I have
> to type the entire username, after which the associated password is
> autocompleted. Hitting the down arrow (up front or after typing a partial
> username) does nothing.
> 
> I have repeatedly attempted to migrate from Mozilla to Firefox, but have always
> ended up going back largely because of this annoyance.
> 

I have been experiencing the same situation exactly as you have reported, since upgrading to FF 1.5 also.  I hope it is fixed soon as it is a major annoyance/hinderance!

Comment 57

12 years ago
Osioke, see comment 55. Your problem is unrelated to this bug and, as such, this is the wrong place to raise it. Either way, Bugzilla is intended for technical commentary and discussion on how to fix the bug. Please visit the MozillaZine support forums.

Comment 58

12 years ago
I have the same problem as comment 54 and 56 and I do not understand the suggestions on 55 and 57.

Comment 59

12 years ago
Someone really has to explain to me the logic of Fx guys about their priorities. How can such a bug remain open for such a long time? IE does it very well.
Flags: blocking-firefox2?
Multiple active usernames per site is not the most common case, and no one has stepped up to fix this.  It'd be nice to fix, but we're at the point where we're going to start cutting down the blocker list, not add more functionality changes.
Flags: blocking-firefox2? → blocking-firefox2-

Comment 61

11 years ago
What is the source of the assertion in comment #60?  

I just reviewed the list in my Password Manager.  I have the following:

2 entries for accounts at our county library, one for me and one for my wife

4 entries for accounts in my ISP's spam manager, one for my E-mail, one for my wife's E-mail, and two for the E-mail accounts of a charity that I head

2 entries for managing accounts at FreeFind (a free Web-site search engine), one for my Web site and one for the charity's Web site

2 entries for accounts at a major mutual fund group, one for my account and one for my wife's account

2 entries at a domain registry, one for my personal domain and one for the charity's domain

2 entries at Social Security Online, one for my account and one for my wife's account
Flags: wanted1.8.1.x?
Flags: wanted1.8.1.x?
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.2?

Comment 62

11 years ago
Any progress on this?  It'll be nice to take it for the next release if we can get a patch together and tested.
I don't know if the risk/benefit is there, unless we're completely disabling autofill...  Nice to fix on trunk, but we're nowhere near a sane idea of what we'd do here, let alone working on it.
Flags: wanted1.8.1.x+
Flags: blocking1.8.1.2?

Updated

11 years ago
Blocks: 376668

Comment 64

10 years ago
Is this bug really different from bug 227632?  For a while (1.5 yr), this bug blocked bug 227632.  
[Yes, as I explained in 227632. No need to ask the same question twice in both bugs.]

Updated

10 years ago
Duplicate of this bug: 414108
Cleaning up the buglist by making this a dupe of 376668. This bug is older, but that bug is really targeting the general problem instead of the specific solution that has been argued in this bug. [Even though it happens that the last idea on the table is basically the same thing.]
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376668
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.