Mail database breaks if INBOX is larger then 2GB (31 bit)

RESOLVED DUPLICATE of bug 207400

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 207400
14 years ago
9 years ago

People

(Reporter: Niels Mache, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4.1) Gecko/20031008
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4.1) Gecko/20031008

This bug is confirmed with all versions of Mozilla (with Windoze 2000 operating
system). It seems that Mozilla has a 2GB (31 bit) limitation for the maximum
file size of mail files (confirmed under Windows2000, NTFS filesystem). It seems
that mail files can not grow larger then 2 GByte. 

Since a while my inbox is larger then 2GB and I am used to synchronize my email
to read email offline. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
The Inbox got unreadable after approching the 2GB filesize barriere. I tried
everything to get Mozilla Mail working again. I removed the .msf Files to
rebuilt the database, removed the INBOX and .msf file, etc.

Result: INBOX got unreadable if getting larger then 2GB. The mail data is
*completly* lost.  


Expected Results:  
Implementing 64-bit filepointers and fileaccess when runnig on an appropriate
operating and file system.

Comment 1

14 years ago
A work around is to compact folder every time you delete a mail, and you will go
under a 2 Gb mailbox :)
Summary: Mail database breaks if INBOX is larger then 2GB (31 bit) → Mail database breaks if INBOX is larger then 2GB (31 bit)

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 207400 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.