Closed Bug 207400 Opened 17 years ago Closed 16 years ago

Mail not being displayed when mail file exceeds 2GB in size. When I move email to another folder, list of emails in inbox is lost.

Categories

(MailNews Core :: Backend, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: neeraj_ahuja, Assigned: Bienvenu)

References

Details

(Keywords: dataloss)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

My mail server at work is MSOutlook 2000 (SR-1 9.0.0.3821).  I use Mozilla
instead to read and reply my email.  Yesterday, I noticed that Mozilla would not
display any message content for any messages in my inbox.  The display pane for
the messages is blank.  When I double-click the message, I see the menu bar and
the mail icons but the content of the messages and such are blank.  I can see
the subject line of all email messages (old and new).  The message list updates
as I receive new messages and delete some I do not want to read.

I deleted the inbox.msf file and forced mozilla to rebuild it.  Still, I see the
 empty mail messages.  I upgraded Mozilla as well (from 1.3 to 1.3.1) and still
see the same problem.  I cleaned up some mail yesterday.  When I came back this
morning, I could see the contents of the mail messages.  However, later in the
afternoon, after I received more mail, I see the same problem of the empty email
messages.  

On the main Mozilla Mail window, I click on the "Edit" menu and choose
"Preferences".  I choose "Offline & Disk Space".  The "Compact folders when it
will save over __ KB" option is unchecked.  Thus it is not this compacting
action on the inbox messages that is causing this.

When I verified size of the inbox file, it is 2GB (2,097,333KB).  The other
folders are much smaller than this and I have no problem seeing messages in
those. To verify this is so, I moved some email from my 'Inbox' into another
local folder.  My list of emails in the upper pane disappeared! It completely
blanked out!! I had to shut down all Mozilla windows, delete 'Inbox.msf' file
and recreate the list of emails in 'Inbox'!

Another symptom - during the last couple of days, I noticed Mozilla being very
slow when I wanted to preview email messages.

Reproducible: Always

Steps to Reproduce:
1. Filesize of 'Inbox' is over 2GB. Open file.  You cannot view email messages.
2. Shutdown Mozilla (Mail and browser). Delete 'Inbox.msf' file.
3. Open Mozilla. Mail rebuilds msf file.  You can view all email subject line,
sender of email, size of email, etc. Cannot view contents of email in preview
pane below.
4. Double-click email to open separate window.  Email window is blank.
5. Move few emails from 'Inbox' to another local folder.  All list of emails in
top pane disappears!!
6. Shut down all Mozilla windows.
7. Repeat steps (1), (2) and (3) above to recreate list of emails in 'Inbox'.

Actual Results:  
After step 4 above, Email window is blank.
After step 5 above, list of emails in top pane disappears!

Expected Results:  
Should be able to display my email messages every time.  If there are issues
with size of 'Inbox' limitations, Mozilla must flag this as an warning message.
Here are additional details on problems I encountered -

When I executed steps (5) through (7) listed in 'Steps to reproduce' below, I 
noticed that all my email in my Outlook Inbox vanished!!!  I requested my IT 
department to restore my email from backup, which they did.  When I opened the 
Mail browser again, it tried to open my Inbox once again.  When it did, it said 
in the status bar (bottom left corner of screen) 'Compacting folder'.  As it 
proceeded, I noticed all my email in my Inbox in Outlook disappearing once 
again!!!  My IT department restored my email once again. 

Additional info for debugging =
Size of Mozilla 'Inbox' file = noted below
Size of Mozilla 'Inbox.msf' file = 1427 KB
Total diskspace used when problem occurred = 5.69 GB
Total diskspace free when problem occurred = 5.12 GB

If Mozilla wants to compact folder before it wants to read it, it seems to me 
that it wants to free up some memory to read. I will have to move most of my 
Outlook Inbox into a local folder (and thus reduce its footprint) and then try 
to use Mozilla to access remainder items in Inbox.  I am hesitant to try this 
due to the problems I already caused my IT dept.  I leave this as a case to the 
testers verifying the fix to this issue.
*** Bug 208039 has been marked as a duplicate of this bug. ***
I tried MacOS or Windows 2000 also have the same problem
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dataloss
Attached image Image Unable to write
Same here. 2GB inbox on local pc using POP3, mozilla 1.4a or Netscape 7.x on
Win2k or WinXP cannot add to or edit. Same inbox can be accessed through IMAP. 
Any resolutions for POP with inbox> 2GB?
*** Bug 222832 has been marked as a duplicate of this bug. ***
I would expect the limit to be more like 4GB, not 2GB, but perhaps it's a
signed/unsigned thing. We probably should just warn the user if a local mail
folder gets too large.
Assignee: sspitzer → bienvenu
*** Bug 222938 has been marked as a duplicate of this bug. ***
*** Bug 223370 has been marked as a duplicate of this bug. ***
OS -> All, 
according to latest dupe.
OS: Windows 2000 → All
Hardware: PC → All
Depends on: 184452
there are several places in the code that limit mailboxes to 2GB (0x7fffffff) -
one is nsOutputFileStream (used when copying messages to local folders), an
other is nsInputStreamTransport, used when reading a mail message (which is a
limitation of nsISeekableStream)
Status: NEW → ASSIGNED
Depends on: 180154
fixed by checkin to 180154 - now mail folders can be up to 4GB
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Product: MailNews → Core
*** Bug 274377 has been marked as a duplicate of this bug. ***
*** Bug 292857 has been marked as a duplicate of this bug. ***
Is this the 2 gig error reappearring?

When downloading email now I receive the pop up alert from thunderbird 

"there was an error after filtering the message to 'yourfolderhere'. You may need to shutdown Thunderbird and delete INBOX.msf 

My inbox is 2,103,187 KB. Is this the 2 gig error reappearring?
I have compacted it and restarted to no avail. Inbox size stayed the same.
It still happens.

Also moved a folder out from under the inbox area in local folders and compacted it to no avail. Inbox size still stayed the same. It still happens. it happens on every email. I click the ok for the warning and the next email triggers the same thing (whether it is filtered to another folder or not). 

Note: most of my filters COPY email to another folder if it is from someone for example but do not MOVE email from my inbox (so I can read the whole stream if I want or jump to a folder to see if i **** one say from family in the hundreds I get. 

version 1.5.0.12 (20070509)

why is there a limit to email inbox size? 2 gigs is not enough if you are archiving all your email for records purposes.
Status should be  REOPENED
running windows xp

over 6 gig available on my harddisk.
I don't know that that error has to do with a 2GB limit.

And you might want to try 2.0
I just downloaded and 2 0 0 5 .
now thunderbird simply says downloading 1 of x number of messages, but then the motion indicator at top right stops and greys out and the green led that goes left and right also stops.
 
t bird doesn't completely lock up as i can stuill view other mailboxes but it never downloads the message and it doesn't say can't append to the inbox like version  1 8 did.

(have we lost some error message reporting in 2? also is their an error log txt file i can look at?

tbird did reindex all my mailboxes on first open.

somethings wrong and switching to 2 did not fix it. ugh.
also sometimes the error was reported in version 1.5.0.12 as cannot append to inbox or something similiar. ( version 2 0 0 5 just stops and doesnt report any error even though it can't add to the inbox.)
newly reported bug 378142 seems like this has reappearred
This bug absolutely positively is still there.
I just proved it by making tbird work again after reducing my inbox to under 2 gig.

I just used a duplicate removal addon to get ride of many emails in my inbox and compacted it. when it got to 1 gig instead of 2.1 gig tbird version 2 0 0 5 is now happily downloading the 8000 message that have accumulated on my server since last week when tbird stopped downloading as my inbox got to 2.1 gig in size.

This is a critical error.
Product: Core → MailNews Core
My inbox recently reached the size of 2GiB.
So I received new mails, but they are unreadable or the text is the one from an other mail.
Now I create a new directory and it seem to be good.

This critcal error seems to be still active !
I've never look to the size of the thunderbird files in my profiles like, I think, many (the most) users...
Why don't create a warning with the ability to automatically create a new directory with the old mails to ease the inbox
You need to log in before you can comment on or make changes to this bug.