Non-permanent freeze on move message(s)

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED FIXED
14 years ago
8 years ago

People

(Reporter: David Mytton, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: Mozilla Thunderbird 0.3 (20031013)

When I select 1 or more messages in my inbox and move them to my 'Read' folder 
(which I created), it takes up to 30 seconds to actually complete. The program 
acts as if it has frozen at this point until the move is completed when the 
program runs fine again. This did not occur when I installed fresh but I have 
imported several thousand messages in from Outlook. The 'Read' folder I'm 
moving to has over 8500 messages in it. However, moving a message from the 
inbox of another account to the 'Read' folder reproduces the problem even 
though this folder has about 820 messages in it. But, if I move a message from 
the Inbox of another account to its 'Read' folder (with no messages in it), the 
move is done with no delay.

Reproducible: Always

Steps to Reproduce:
1. Select 1 more more messages in the inbox
2. Right click and select Move

Actual Results:  
As described in the 'Details' field

Expected Results:  
Move almost instantly or at least within a secon.

Seems to slow down when large numbers of messages are involved.
I am also expericing same problem with Mozilla trunk these several weeks and
still occurs on Mozilla 2003102804-trunk/Win-Me.
Mozilla freezes for a while when ;
 (a) mails arrived(POP3)
 (b) and some mails are moved to folder by mail filter
 (c) and clicked the folder just after notification of mail arrival

".msf" recreation on folder open after move mail?
Bug 218477 is probably same bug for Mozilla Mail&News.
(Reporter)

Comment 3

14 years ago
This is still in the current version of TB: version 0.6 (20040502)

Comment 4

14 years ago
how big is the read.msf file?
(Reporter)

Comment 5

14 years ago
To counter this problem, I created a sub folder of the 'Read' folder 
called 'Archives' and periodically, I move all my messages into it, then 
compact both folder. This means the 'Read' directory has no messages in it and 
so moving mail is instant.

In my Profiles\default\fngw9xco.slt\Mail\Read.sbd I have 2 files:

Archives - 116,408Kb
Archives.msf - 4715Kb

This is my largest mailbox which has 13447 messages in it.
My case (Comment #1) was found to be caused by my setting of WinAMP as player of
.WAV file.
When WinAMP is used, playing .WAV file on mail arrival takes long time(same time
as starting WinAMP graphical interface), and this causes almost freeze of
requester. 
I changed player of .WAV file to mplayer2.exe and my problem was resolved. 
 
(Reporter)

Comment 7

14 years ago
I don't have WinAMP installed and this isn't a problem when I receive mail - it 
is moving it around the mailboxes.
(Reporter)

Comment 8

14 years ago
This seems to be fixed in version 0.7a (20040614) I just installed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.