[Deploy]Need doc on AutoConfig and Config files

RESOLVED INVALID

Status

Developer Documentation
General
P3
normal
RESOLVED INVALID
14 years ago
5 years ago

People

(Reporter: Daniel Wang, Assigned: sheppy)

Tracking

(Blocks: 1 bug)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
Need doc to expand on bug 158384
(Reporter)

Updated

14 years ago
Depends on: 222974

Updated

14 years ago
(Reporter)

Updated

14 years ago
Blocks: 178685
(Reporter)

Updated

14 years ago
QA Contact: imajes → stolenclover

Comment 1

14 years ago
I'am glad you finally made it work

we are about to form a community that use mozilla autoconfig, and hopefully
we'll be enough to assure that developpers keeps make this unvaluaible feature
work, and maybe more documented ....

there are several bug reports opened related to autoconfig, feel free to
contribute and/or vote !

http://bugzilla.mozilla.org/show_bug.cgi?id=229271
http://bugzilla.mozilla.org/show_bug.cgi?id=206294
http://bugzilla.mozilla.org/show_bug.cgi?id=222973
http://www.mail-archive.com/mozilla-documentation@mozilla.org/msg02784.html

aschroe1 wrote:

> jehan.procaccia schrieb:
>
>> getenv OK , just check in shell that the value of USER is what is expected :
echo $USER
>> your locPref above is wrong , don't add the "+" sign ! you (an I !) use +
sign in the the javascript file to concatenate strings, here you just have to
call the string:
>> lockPref("mail.identity.id1.useremail", env_user );
>
>
>
> Hello,
> I've got the solution; I dont't believe really   
>
> -the first line of my js/cfg script has to begin with   //
> -your tip leaving out the "+" sign in fornt of the variable
>  (I tried this before, but without the first comment line)
> that's it!     zzzz..zzzz..zzzzz
>
> Thank you very much for your support,
> merci bien  (just another two of my few french words)     :- ))
>
> -------------------------------------------------------------
> Alfred Schroeder - Lernstatt Paderborn -
>
> aschroe1@lspb.de
> ------------------------------------------------------------- 
(Reporter)

Comment 2

13 years ago
references (from bug 241534)
http://www.alain.knaff.lu/howto/MozillaCustomization/index.html
http://thegoldenear.org/toolbox/windows/docs/mozilla-pre-config.html
http://www.int-evry.fr/mci/user/procacci/netscape/en/mozilla-autoconfig-en.html
Assignee: endico → nobody
Blocks: 226876
Summary: Need doc on AutoConfig and Config files → [Deploy]Need doc on AutoConfig and Config files
(Reporter)

Comment 3

13 years ago
Created attachment 152002 [details]
Configuration Configuration and Auto-Admin reference

WIP from bug 178685

Comment 4

13 years ago
Thanks for you documentation (attachement) and the wonderfull pages you opened on 
http://wangrepublic.org/daniel/mozilla/prefs/ thanks to bugid=178685 :-).
However (I haven't read everything yet ...) I noticed on mozilla 1.7 on windows
palteform at least, that there's no more all.js file. To bad .. it's where I set
my general.config.filename directive for mozilla auto-config, cf:
http://www.int-evry.fr/mci/user/procacci/netscape/en/mozilla-autoconfig-en.html
should I set it somewhere else or create an empty all.js file containing only
that directive ?
Thanks.

Comment 5

13 years ago
Now I see that all.js file is opened on a different folder since 1.7.2 on linux.
it used to be in MOZILLA_HOME(here /usr/lib/mozilla-1.7.3/)/default/pref, now
it's in MOZILLA_HOME/grepref/ . 
The problem is that this directory is by default only readable by root (700), so
users on my stations that use mozilla autoconfig (general.config.filename
directive in all.js) don't get the autoconfiguration set anymore :-( .

A workaround is to set grepref directory to 755, but is this safe ?
Second question, where should I but general.config.filename directive in the
future (default/pref/all.s or grepref/all.js ?)

thanks.

PS: I will update my mozilla autoconfig doc in consequence ...
http://www.int-evry.fr/mci/user/procacci/netscape/en/mozilla-autoconfig-en.html

Comment 6

12 years ago
Gregg Berkholtz wrote:

> In bug 222973, you mentioned that setting up a community to help track and/or
manage Mozilla/Firefox/Thunderbird enterprise needs. Did you ever do this? If
so, how do we join?

Jehan Procaccia writes :

no, I've just hoppened several bug on bugzilla, but that's all .
Actually I don't know how many people use autoconfig, but this tool is very
usefull ! and I hope it will still work with firefox/thunderbird (I haven't
tested yet, but in next september our 2000 students will use  Fedora Core 3 or 4
which comes with these tools now ...)

Do you have an idea on how to create or maybe join an already existing
autoconfig user's community ?

Comment 7

12 years ago
I've created a guide describing how to setup Autoconfig with Mozilla Firefox.
Take a look:
http://mit.edu/~firefox/www/maintainers/autoconfig.html

I also have a brief writeup describing how autoconfig is setup at MIT, and a
link to the relevant files:
http://mit.edu/~firefox/www/maintainers/config.html

Comment 8

12 years ago
(In reply to comment #7)
> I've created a guide describing how to setup Autoconfig with Mozilla Firefox.
> Take a look:
> http://mit.edu/~firefox/www/maintainers/autoconfig.html
> 
> I also have a brief writeup describing how autoconfig is setup at MIT, and a
> link to the relevant files:
> http://mit.edu/~firefox/www/maintainers/config.html

Charles has done an excellent job here of documenting the baroque Mozilla
configuration process. But it would be much better if the software was changed
so that much of the complexity vanished. For example:
(1) The configuration file should not have to reside in the software directory,
because that way it is highly likely to get lost or overwritten whenever the
software is upgraded. Instead the software should follow Unix FHS standards and
look in /etc/opt/mozilla/ (perhaps followed by some other places).
(2) There should be a sensible default name, e.g. siteprefs.cfg. At the moment
the administrator has to use the old complicated user preference scheme just to
enable the new simpler one.
(3) What on earth is the ROT13 business for? The default should be to accept a
plain text file (and maybe accept ROT13 for backward compatibility). 

My comments are Unix-orientated; I guess Windows doesn't have an equivalent of
the /etc directory. But  if these changes were made then most of section 2 could
be eliminated and replaced by something like

You need to put your site preferences in a file called siteprefs.cfg. On Unix
this file should be put in the directory /etc/opt/mozilla; on Windows put it in
the base of the Mozilla installation directory. 

Bob
QA Contact: danielwang → www-mozilla-org

Comment 9

10 years ago
FYI, I've just updated the doc on autoconfig/MCD feature on mozilla products with TB 2 beta 2 and firefox 2.x

http://developer.mozilla.org/en/docs/MCD%2C_Mission_Control_Desktop_AKA_AutoConfig#Thunderbird_2.x_beta_2

http://developer.mozilla.org/en/docs/MCD%2C_Mission_Control_Desktop_AKA_AutoConfig#Firefox_2.x

Updated

9 years ago
Product: mozilla.org → Websites

Comment 10

9 years ago
Moving to Mozilla Developer Center product.
Component: www.mozilla.org → Documentation Requests
Product: Websites → Mozilla Developer Center
QA Contact: www-mozilla-org → doc-request
Version: other → unspecified

Updated

8 years ago
OS: Windows 98 → All
Hardware: x86 → All
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Automatically closing all bugs that have not been updated in a while. Please reopen if this is still important to you and has not yet been corrected.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Reopening for review by Sheppy.
Assignee: nobody → eshepherd
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 13

5 years ago
I'm closing this; the build/setup docs are pretty decent, plus the build system is going through changes that will make this moot even if it's not covered anyway.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → INVALID
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
You need to log in before you can comment on or make changes to this bug.